Bug 1027125 - [RHSC] - No event message generated when remove-brick is started/stopped from CLI.
[RHSC] - No event message generated when remove-brick is started/stopped from...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Sahina Bose
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 03:33 EST by RamaKasturi
Modified: 2015-05-13 12:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 22078 None None None Never

  None (edit)
Description RamaKasturi 2013-11-06 03:33:36 EST
Description of problem:
No event message generated when remove-brick is started/stopped from CLI.

Version-Release number of selected component (if applicable):

rhsc-2.1.2-0.22.master.el6_4.noarch
How reproducible:
Always

Steps to Reproduce:
1. Create a distributed volume and start it.
2. Now from gluster CLI , start remove brick by using the command "gluster volume remove-brick <volName> <brickName> status
3.

Actual results:
In the UI there are no event messages generated when remove brick is started from CLI.

Expected results:
An event message should be generated saying "Remove-brick is started on volume <volName>

Additional info:
Comment 1 RamaKasturi 2013-11-06 03:34:30 EST
The above needs to be fixed for remove brick stop as well.
Comment 3 RamaKasturi 2013-12-12 07:59:09 EST
Verified in cb11 rhsc-2.1.2-0.27.beta.el6_5.noarch.

The following message comes when remove-brick is started from CLI "Detected start of brick removal for bricks <brickName> on volume <volname> of Cluster <clusterName> from CLI."

Attcahing the screen shot for the same.

Logging a separate bug for remove-brick stop from CLI does not generate an event message.

https://bugzilla.redhat.com/show_bug.cgi?id=1040973
Comment 5 errata-xmlrpc 2014-02-25 02:59:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.