Bug 1027130 - edit-node: Better to rename iso_name more simpler when install multiple packages
edit-node: Better to rename iso_name more simpler when install multiple packages
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Joey Boggs
bugs@ovirt.org
node
:
Depends On:
Blocks: 1040827
  Show dependency treegraph
 
Reported: 2013-11-06 03:41 EST by haiyang,dong
Modified: 2016-02-10 14:39 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1040827 (view as bug list)
Environment:
Last Closed: 2014-10-17 08:34:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20951 None None None Never

  None (edit)
Description haiyang,dong 2013-11-06 03:41:26 EST
Description of problem:
Let edit-node install multiple packages
 edit-node --repo=edit-node.repo --install-plugin=ovirt-node-plugin-snmp-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm,ovirt-node-plugin-cim-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm ovirt-node-iso-3.1.0-0.999.1199.el6.iso 
...
 94.35% done, estimate finish Wed Nov  6 06:51:55 2013
 98.83% done, estimate finish Wed Nov  6 06:51:56 2013
Total translation table size: 2048
Total rockridge attributes bytes: 6547
Total directory bytes: 14336
Path table size(bytes): 80
Max brk space used 1b000
111301 extents written (217 MB)
Inserting md5sum into iso image...
md5 = 00d74b083ad0a5b54ab10045fbdfae6d
Inserting fragment md5sums into iso image...
fragmd5 = 87838e6ed15ca529cda43e5c26d925f76dc5fd57723577cdbb1b43c9b732
frags = 20
Setting supported flag to 0
Moving 'ovirt-node-iso-3.1.0-0.999.1199.el6.iso.edited.iso' to 'ovirt-node-iso-3.1.0-0.999.1199.snmp-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm,cim.el6.iso'
You have new mail in /var/spool/mail/root
[root@dhcp-11-127 home]# ls ovirt-node-iso-3.1.0-0.999.1199.snmp-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm,cim.el6.iso
ovirt-node-iso-3.1.0-0.999.1199.snmp-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm,cim.el6.iso

we noticed that it rename iso_name as "ovirt-node-iso-3.1.0-0.999.1199.snmp-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm,cim.el6.iso"
so it's better to rename iso_name more simpler when install multiple packages,
for example like named "ovirt-node-iso-3.1.0-0.999.1199.snmp_cim.el6.iso."


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1199.el6.iso
ovirt-node-tools-3.1.0-0.999.20131105150333git40ee7a0.el6.noarch.rpm

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:

Additional info:
Comment 1 Sandro Bonazzola 2014-03-04 04:18:36 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 2 Sandro Bonazzola 2014-05-08 09:55:35 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 3 Sandro Bonazzola 2014-10-17 08:34:45 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.