Bug 1027132 - [RHSC] - Monitoring remove brick stop from CLI does not work.
[RHSC] - Monitoring remove brick stop from CLI does not work.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity high
: ---
: RHGS 2.1.2
Assigned To: Shubhendu Tripathi
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 03:50 EST by RamaKasturi
Modified: 2015-05-13 12:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RamaKasturi 2013-11-06 03:50:37 EST
Description of problem:
Monitoring remove brick stop  from CLI does not work.

Version-Release number of selected component (if applicable):
rhsc-2.1.2-0.22.master.el6_4.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create a distribute volume and start it.
2. Now select one of the brick and click on remove.
3. Now go to gluster cli and run the command "gluster volume remove-brick <volName> <brickName> stop

Actual results:
1) status dialog gets updated with the correct status.
2) stop button does not get disabled from the drop down menu in the activities column.
3) Icon in the activities column does not get updated with the stopped remove-brick icon.
4) Tasks pane just says that remove-brick is started and it hangs.

Expected results:
1) stop button should be disabled from the drop down menu in the activities column.
2) icon in the activities column should get updated with the correct icon.
3) Tasks pane also should get updated with the correct status. It should not hang.

Additional info:
Comment 2 RamaKasturi 2013-11-06 04:00:23 EST
Link to sos reports

http://rhsqe-repo.lab.eng.blr.redhat.com/sosreports/rhsc/1027132/
Comment 3 Dustin Tsang 2013-12-04 11:21:50 EST
verified in rhsc-cb10
Comment 5 errata-xmlrpc 2014-02-25 02:59:20 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.