Bug 1027136 - [RHSC] Host column in the remove-brick status dialog should be sorted.
[RHSC] Host column in the remove-brick status dialog should be sorted.
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
high Severity medium
: ---
: RHGS 2.1.2
Assigned To: anmol babu
Shruti Sampat
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 03:56 EST by Shruti Sampat
Modified: 2015-05-13 12:27 EDT (History)
7 users (show)

See Also:
Fixed In Version: cb9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:59:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 20746 None None None Never

  None (edit)
Description Shruti Sampat 2013-11-06 03:56:49 EST
Description of problem:
------------------------
The hosts column in the remove-brick status dialog is not sorted, which causes the rows to flip, each time refresh occurs. The hosts column needs to be sorted based on the names of the hosts.

Version-Release number of selected component (if applicable):
Red Hat Storage Console Version: 2.1.2-0.22.master.el6_4 

How reproducible:
Always

Steps to Reproduce:
1. Start remove-brick on a volume.
2. Click on the arrow beside the remove-brick icon in the Activities column, and click on Status button.

Actual results:
Hosts column is not sorted, and the rows keep flipping each time the refresh occurs.

Expected results:
Host column needs to be sorted based on host-names.

Additional info:
Comment 2 Shruti Sampat 2013-11-26 07:40:11 EST
Verified as fixed in Red Hat Storage Console Version: 2.1.2-0.25.master.el6_5. Hosts now listed in sorted order.
Comment 4 errata-xmlrpc 2014-02-25 02:59:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.