Bug 102738 - dhcp init script should have a "configtest" option similar to apache's
dhcp init script should have a "configtest" option similar to apache's
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: dhcp (Show other bugs)
2.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 10:41 EDT by Need Real Name
Modified: 2007-11-30 17:06 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-20 11:49:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-08-20 10:41:13 EDT
Description of problem:

dhcpd supports a "test" option (-t) that can be used to check the validity of
the dhcpd.conf.  Apache already has a "configtest" to do similar, so since dhcpd
supports configuration testing as well, it should honor that option in its init
script, too.

Something like this should be sufficient:

@@ -67,8 +67,12 @@
        status dhcpd
        RETVAL=$?
        ;;
+  configtest)
+       dhcpd -t
+       RETVAL=$?
+       ;;
   *)
-       echo $"Usage: $0 {start|stop|restart|condrestart|status}"
+       echo $"Usage: $0 {start|stop|restart|condrestart|configtest|status}"
        exit 1
 esac
Comment 1 Daniel Walsh 2003-08-20 11:49:34 EDT
Updated packages in next release dhcp-3.0pl2-6.12.src.rpm
Comment 2 John Flanagan 2004-12-21 14:42:20 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-566.html

Note You need to log in before you can comment on or make changes to this bug.