Bug 102739 - gdm isn't setting up session properly
gdm isn't setting up session properly
Status: CLOSED NOTABUG
Product: Red Hat Linux Beta
Classification: Retired
Component: gdm (Show other bugs)
beta1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Havoc Pennington
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 10:47 EDT by Pat Gunn
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-29 11:48:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pat Gunn 2003-08-20 10:47:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030701

Description of problem:
I have a user who's using WindowMaker, and have found that
gnome-session, instead of gdm, is doing some hardware (soundcard,
specifically) initialization, so I need to do a root login before
the user logs in locally in order for sound to work properly.
gdm should be doing this, so the user can choose their window
manager.

Version-Release number of selected component (if applicable):
gdm-2.4.1.3-8

How reproducible:
Always

Steps to Reproduce:
1.Boot up
2.Login with a nonprovided window manager
3.See things not work
4.Get frustrated
    

Actual Results:  Sound did not work

Additional info:
Comment 1 Havoc Pennington 2003-08-29 10:30:30 EDT
I don't know of any sound card setup in gnome-session. 
Can you give details on how you are testing sound and what 
error messages you see if any?
Comment 2 Pat Gunn 2003-08-29 10:35:51 EDT
I'm sorry -- with additional testing, it turns out to be unrelated to
the root login -- it's just that the driver for my sound card sometimes
doesn't initialize things correctly. 
Comment 3 Havoc Pennington 2003-08-29 11:48:53 EDT
OK, thanks. Sounds like a kernel issue.

Note You need to log in before you can comment on or make changes to this bug.