This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1027476 - /usr/libexec/lcrso/{openaisserviceenable,service_amf,service_ckpt,...}.lcrso set executable needlessly
/usr/libexec/lcrso/{openaisserviceenable,service_amf,service_ckpt,...}.lcrso ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openais (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-06 17:27 EST by Jan Pokorný
Modified: 2014-01-06 07:48 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 07:48:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-11-06 17:27:19 EST
# for p in $(for i in /usr/libexec/lcrso/*; do rpm -qf "${i}"; done \
  | sort -u); do echo "${p}:"; rpm -ql "${p}" \
  | grep -F /usr/libexec/lcrso/; done
> [...]
> openais-1.1.1-7.el6.x86_64:
> /usr/libexec/lcrso/openaisserviceenable.lcrso
> /usr/libexec/lcrso/service_amf.lcrso
> /usr/libexec/lcrso/service_ckpt.lcrso
> /usr/libexec/lcrso/service_clm.lcrso
> /usr/libexec/lcrso/service_evt.lcrso
> /usr/libexec/lcrso/service_lck.lcrso
> /usr/libexec/lcrso/service_msg.lcrso
> /usr/libexec/lcrso/service_tmr.lcrso
> [...]

# /usr/libexec/lcrso/openaisserviceenable.lcrso
> Segmentation fault (core dumped)
Comment 2 Jan Friesse 2014-01-06 07:48:33 EST
Libraries (*.so) files are generally created executable (and lcrso is just renamed so). Only very few libraries contains valid entry point (libc does, pthread does, ld.so does). Vast majority of libraries execution ends with segfault. Take a look to /lib{64} or /usr/lib{64}.

Executable bit is also used on some platforms (like hp-ux) and without it, dl_open doesn't work.

Generally, I don't have any intent to solve this in RHEL 6, because possible breaking compatibility and general nonsense of such action. RHEL 7 corosync doesn't include lcrso so it's already solved there.

Note You need to log in before you can comment on or make changes to this bug.