Bug 1027602 - apper crashed every time when click the Application icon in the Categories
apper crashed every time when click the Application icon in the Categories
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: apper (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 03:17 EST by lnie
Modified: 2014-10-29 10:14 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-29 10:14:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
RC4 (165.83 KB, image/png)
2013-11-07 21:45 EST, lnie
no flags Details
Rc5 (407.31 KB, image/png)
2013-11-07 21:45 EST, lnie
no flags Details
crashscreen (140.46 KB, image/png)
2013-11-07 21:50 EST, lnie
no flags Details

  None (edit)
Description lnie 2013-11-07 03:17:00 EST
Description of problem:
Run apper ,click the Application icon to search for some package which is not installed ,apper crashed immediately 
Version-Release number of selected component (if applicable):
 f20-beta-RC4
How reproducible:
always

Steps to Reproduce:
1.Do a fresh install on VM
2.run apper
3.click the Application icon in the Categories 

Actual results:


Expected results:


Additional info:
Comment 1 Ricardo Varas 2013-11-07 20:59:57 EST
I am unable to reproduce this bug. Steps taken:

1- Run Apper
2- Click Categories>Applications
3- Click Text-based Internet
4- Search for tftp
5- Enter root password when requested
6- Click Apply

It works for me.

Name        : apper
Arch        : i686
Version     : 0.8.1
Release     : 1.fc20
Size        : 4.2 M
Repo        : installed
From repo   : koji-override-0
Comment 2 lnie 2013-11-07 21:44:35 EST
  Hi Ricardo,which fedora version you used,RC4 or RC5?As you can see from the attachments,RC4 and RC5 have different icons in apper.I'm unable to see Categories in RC5.I saw your report in the KDE testday page.I also use a kvm virtual machine to do this test.My system is x86_64,yours is i686,may be that's the crash reason?
Comment 3 lnie 2013-11-07 21:45:06 EST
Created attachment 821418 [details]
RC4
Comment 4 lnie 2013-11-07 21:45:41 EST
Created attachment 821419 [details]
Rc5
Comment 5 lnie 2013-11-07 21:48:47 EST
BTW,my apper version is also 0.8.1
Comment 6 lnie 2013-11-07 21:50:48 EST
Created attachment 821420 [details]
crashscreen
Comment 7 lnie 2013-11-07 22:11:33 EST
After a reboot,Rc5 has the same icons in apper now.The first time I click the 
Applications,there is no crash happened.But after I install and remove some packages,and reboot the system,the apper in  RC5 crashed immediately as in the RC4
Comment 8 lnie 2013-11-08 02:02:09 EST
As for the default installed packages:I'm only  able to find one package,ibus-chewing, in the hundreds of packages that can be remove successfully
Comment 9 Ricardo Varas 2013-11-08 14:08:27 EST
Right, this could be because of the different architectures. I will try to download an x86_64 image and install in the VM. Also, I did an upgrade before testing so chances are I was at RC5.
Comment 10 Rex Dieter 2014-10-29 10:14:54 EDT
Without a backtrace, let's assume this was a problem specific to f20 prereleases,

Note You need to log in before you can comment on or make changes to this bug.