Bug 102769 - netstat -i eth0 errors
netstat -i eth0 errors
Status: CLOSED DUPLICATE of bug 61113
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-20 15:59 EDT by Ulf Zimmermann
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulf Zimmermann 2003-08-20 15:59:16 EDT
Description of problem:

Man page of netstat states:

       netstat {--interfaces|-i} [iface] [--all|-a] [--extend|-e[--extend|-e]]
       [--verbose|-v]      [--program|-p]      [--numeric|-n]      [--numeric-
       hosts][--numeric-ports][--numeric-ports] [--continuous|-c]

   --interface=iface , -i
       Display a table of all network interfaces, or the specified iface).


Version-Release number of selected component (if applicable):

net-tools-1.60-12

How reproducible:

Every time

Steps to Reproduce:

1. netstat -i eth0
2. netstat --interface=eth0
3.
    
Actual results:

1. netstat will print out usage message

2. netstat will print out usage message and in addition:

netstat: option `--interfaces' doesn't allow an argument

Expected results:

Print out the statistic of eth0 only

Additional info:
Comment 1 Phil Knirsch 2003-08-25 10:37:35 EDT
Just remembered, this has been entered before.

I've patched netstat over the weekend to work according to the manual and will
fix the usage output. The next net-tools rawhide version will contain the fix.

By default netstat will use all interfaces (as it used to do) but a single
interface to be monitored can be specified now, too (-ieth0 or --interface=eth0)

Read ya, Phil



*** This bug has been marked as a duplicate of 61113 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:58:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.