Bug 1027999 - virt-viewer can not change the resolution higher than physical size in windowed mode
virt-viewer can not change the resolution higher than physical size in window...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-viewer (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Virt Viewer Maint
Virtualization Bugs
:
Depends On:
Blocks: 1113520
  Show dependency treegraph
 
Reported: 2013-11-07 08:49 EST by tingting zheng
Modified: 2014-07-07 07:09 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-06 18:31:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Debug info of virt-viewer (255.25 KB, text/plain)
2013-11-07 08:49 EST, tingting zheng
no flags Details

  None (edit)
Description tingting zheng 2013-11-07 08:49:05 EST
Created attachment 821141 [details]
Debug info of virt-viewer

Description
virt-viewer can not change the resolution higher than physical size in windowed mode

Version:
Host:
libvirt-1.1.1-11.el7.x86_64
virt-viewer-0.5.7-2.el7.x86_64
spice-gtk-0.20-6.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
spice-glib-0.20-6.el7.x86_64

Guest:rhel6.5
spice-vdagent-0.14.0-2.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Prepare a spice guest,install spice-vdagent,start spice-vdagentd service.
2.# virt-viewer guest
3.Change the resolution from guest,it can change resolution lower than physical size,but fail to set as higher than physical size in windowed mode.
first resolution:1024*768
A.change resolution to 1280*720,failed,back to 1272*720.
B.change resolution to 1360*768,failed,back to 1272*768.
C.change resolution to 960*640,success.

Actual results:
As description.

Expected results:
virt-viewer can change the resolution higher than  physical size in windowed mode

Additional info:
1.The issue can not be reproduced on rhel6.
2.The issue can not be reproduced on full-screen.
3.Attached spice-debug info.
Comment 1 hyao@redhat.com 2013-11-21 01:22:47 EST
I can reproduce the bug with the following packages:

On host:
# rpm -qa libvirt virt-viewer spice-gtk spice-vdagent spice-gtk3 spice-server spice-glib
virt-viewer-0.5.7-1.el7.x86_64
spice-glib-0.20-6.el7.x86_64
spice-vdagent-0.14.0-5.el7.x86_64
spice-gtk3-0.20-6.el7.x86_64
spice-gtk-0.20-6.el7.x86_64
spice-server-0.12.4-3.el7.x86_64
libvirt-1.1.1-12.el7.x86_64

On guest: rhel6.5
spice-vdagent-0.14.0-2.el6.x86_64
Comment 2 Marc-Andre Lureau 2014-07-06 18:31:29 EDT
This is by design, there is code in virt-viewer to resize the display to fit the native client resolution while keeping aspect-ratio in window mode.

Note You need to log in before you can comment on or make changes to this bug.