Bug 1028077 - LastUser not saved
LastUser not saved
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: sddm (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Martin Bříza
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 10:51 EST by nucleo
Modified: 2013-11-12 12:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 11:32:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nucleo 2013-11-07 10:51:00 EST
Description of problem:
LastUser not saved.

Version-Release number of selected component (if applicable):
sddm-0.2.0-0.20.20130914git50ca5b20.fc20

Steps to Reproduce:
1. Set RememberLastUser=true in /etc/sddm.conf.
2. Start session.
3.

Actual results:
No saved last iser in LastUser= in in /etc/sddm.conf.

Expected results:
Last user should be saved.
Comment 1 nucleo 2013-11-07 11:04:06 EST
Last session also not saved. KDE Plasma Workspace selected after previous failsafe session.
Comment 2 Kevin Kofler 2013-11-12 11:06:23 EST
Could this be SELinux blocking the write to the config file?
Comment 3 nucleo 2013-11-12 11:22:18 EST
With selinux=0 previous user and session saved.
Comment 4 nucleo 2013-11-12 11:32:57 EST
Now everything works fine even without disabling selinux after installing update https://admin.fedoraproject.org/updates/FEDORA-2013-20946
Comment 5 Rex Dieter 2013-11-12 11:39:02 EST
What version of sddm did you have before?

(if something newer than 0.16, then the pam work probably introduced some sort of regression)
Comment 6 nucleo 2013-11-12 12:29:41 EST
Looks like 0.16 saves last user/session but 0.20 testes previously don't. 
I can't test 0.20 now because even session not starts if 0.20 installed.

Note You need to log in before you can comment on or make changes to this bug.