Bug 102814 - Missing BuildRequires in spec file.
Missing BuildRequires in spec file.
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: rhn-applet (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 10:14 EDT by Dams
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-16 20:49:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2003-08-21 10:14:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20030131

Description of problem:
[anvil@gruyere ~]# rpmbuild --rebuild rhn-applet-2.0.10-1.src.rpm
[SNIP]
+ make
Package gtk+-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-2.0' found
Package libgnomeui-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libgnomeui-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'libgnomeui-2.0' found
gcc -fPIC -Wall -g -fomit-frame-pointer -I/usr/include/python2.2
-I/usr/include/pygtk-2.0   -c -o eggtrayiconmodule.o eggtrayiconmodule.c
eggtrayiconmodule.c:1:20: Python.h: No such file or directory
eggtrayiconmodule.c:7:33: pygtk-2.0/pygobject.h: No such file or directory
[SNIP once gtk2-devel, libgnomeui-devel, python-devel, pygtk2-devel installed]
intltool-update --gettext-package=rhn-applet --pot
Can't exec "xgettext": No such file or directory at /usr/bin/intltool-update
line 470.


Installing gtk2-devel, libgnomeui-devel, python-devel, pygtk2-devel and gettext
fixed build problems. Please add them as BuildRequires in spec file.

Version-Release number of selected component (if applicable):
rhn-applet(0:2.0.10-1)

How reproducible:
Always

Steps to Reproduce:
1. rpmbuild
Comment 1 Dams 2003-10-15 12:48:34 EDT
Ping ? rhn-applet-2.1.0-1 srpm still not fixed.
Comment 2 Daniel Veillard 2003-10-16 20:49:56 EDT
Okay, I fixed the problem in 2.1.1 release today, see

http://people.redhat.com/~veillard/testing/yum/rhn-applet/

it should hit rawhide real soon.

  thanks for the report and the reminder,

Daniel
Comment 3 Jay Turner 2004-11-26 03:44:47 EST
Fix confirmed with 2.1.18-4.
Comment 4 John Flanagan 2004-12-21 15:48:53 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-582.html

Note You need to log in before you can comment on or make changes to this bug.