Bug 1028188 - Package Groups do not install on f19 during kickstart
Package Groups do not install on f19 during kickstart
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: 6.0
Assigned To: Katello Bug Bin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 15:56 EST by Justin Sherrill
Modified: 2015-12-03 10:15 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 08:45:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2013-11-07 15:56:33 EST
Description of problem:

Using katello 1.4 kickstarting a fedora 19 machine results in package groups being skipped completely from the kickstart file %packages section.  

'it's complaining about it being in the "old style" yum groups instead of "new style" yum groups'

More investigation needs to be done to determine where the problem lies
Comment 1 Justin Sherrill 2013-11-07 16:01:58 EST
Currently a work around is in the %post section add:


# Convert groups from old style to new style!
yum groups mark convert
 
# Make sure that the group install worked correctly... for the desktop
yum -t -y -e 0 groupinstall core basic-desktop gnome-desktop cinnamon-desktop
 


listing all the groups that you wanted to install in %packages
Comment 2 Bryan Kearney 2014-01-21 14:08:14 EST
Moving to Sat6 to be tracked there. Upstream bugs are moving to redmine.
Comment 3 RHEL Product and Program Management 2014-01-21 14:18:35 EST
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 5 Bryan Kearney 2015-10-13 08:45:13 EDT
This relates to an old Fedora which is no longer supported. If you are seeing this on a newer Fedora, please feel free to re-open.

Note You need to log in before you can comment on or make changes to this bug.