Bug 1028189 - Test case failure: bind on stateless
Test case failure: bind on stateless
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind (Show other bugs)
7.0
All Linux
unspecified Severity high
: rc
: ---
Assigned To: Tomáš Hozza
Juraj Marko
:
Depends On: 1029342
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 15:59 EST by Juraj Marko
Modified: 2015-08-31 23:39 EDT (History)
4 users (show)

See Also:
Fixed In Version: bind-9.9.4-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 06:21:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Tomáš Hozza 2013-11-11 09:52:19 EST
The problem is that /var/named/data is read-only, but named is configured
to store its logs in there and also some other stuff. We need to distribute
"rwtab" configuration together with named so that /var/named/data is mounted
as tmpfs and writeable.

I tested named with the configuration in /etc/rwtab.d/ and it worked (after
restoring context on the mounted /var/named/data dir) I'll file a new bug
on initscripts, since I think they should restore the SELinux context of
the mounted directory.

However named-chroot is not working, too. So I need to figure out how to fix
it.
Comment 3 Tomáš Hozza 2013-11-12 04:27:10 EST
To fix both named and named-chroot, configuration for rwtab has to be added and
also setup-named-chroot.sh script has to be slightly modified.
Comment 8 Ludek Smid 2014-06-16 06:21:02 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.