Bug 1028197 - warn if attaching FOO.img as CDROM to running guest, which is already using FOO.img as a RW disk
warn if attaching FOO.img as CDROM to running guest, which is already using F...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 16:36 EST by Jan Pokorný
Modified: 2014-03-04 01:46 EST (History)
3 users (show)

See Also:
Fixed In Version: virt-manager-1.0.0-3.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-04 01:46:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-11-07 16:36:15 EST
Maybe virt-manager has no knowledge whether the particular image file
is being used as RW --or-- there are use cases for single image backing
multiple VMs in RO mode, so this bug may be either irrelevant or suitable
for any of lower-level virt components.  Also it seems that my "CDROM"
instance will require some decent generalization.

Anyway, my problem was that I tried, as a mistake, "connect" a CDROM
with a disk image (RO boot partition, otherwise RW) of particular
VM to this running VM itself.  Response of the VM (F20 Beta, / as ext4):

> Nov 07 22:13:30 localhost.localdomain kernel:
>   end_request: I/O error, dev vda, sector 7060496
> Nov 07 22:13:30 localhost.localdomain kernel:
>   Buffer I/O error on device vda3, logical block 557698
> Nov 07 22:13:30 localhost.localdomain kernel:
>   lost page write due to I/O error on vda3
> Nov 07 22:13:30 localhost.localdomain kernel:
>   end_request: I/O error, dev vda, sector 7060504
> Nov 07 22:13:30 localhost.localdomain kernel:
>   Aborting journal on device vda3-8.
> Nov 07 22:13:30 localhost.localdomain kernel:
>   end_request: I/O error, dev vda, sector 7055360
> Nov 07 22:13:30 localhost.localdomain kernel:
>   Buffer I/O error on device vda3, logical block 557056
> Nov 07 22:13:30 localhost.localdomain kernel:
>   lost page write due to I/O error on vda3

and as a consequence, /dev/vda3 was remounted as RO and then everything
was bad (in my case until restart with prior "disconnection" of the CDROM).

If I understand what's going on correctly, I think one shouldn't be able
to shoot into her foot so easily, at least not with GUI for (mostly)
inexperienced users.


virt-manager-0.9.5-1.fc18.noarch
libvirt-0.10.2.8-1.fc18.x86_64
qemu-kvm-1.2.2-14.fc18.x86_64
Comment 1 Cole Robinson 2013-12-16 14:24:25 EST
Pretty sure the root issue will apply to F20 as well, so changing version.

So you have a VM using a disk image mydisk.img, that VM is running, and you accidentally attached mydisk.img as a CDROM to the running VM? Yeah, we should warn about that. We already have some infrastructure to warn about in-use disks but perhaps it's missing something here.
Comment 2 Cole Robinson 2014-01-14 17:20:20 EST
Upstream now:

commit 66096a7eebb4e5216f0f5cbba85d1c9539f33532
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Jan 14 17:11:51 2014 -0500

    choosecd: Check path-in-use collision (bz 1028197)
Comment 3 Fedora Update System 2014-02-14 19:56:52 EST
virt-manager-1.0.0-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.0-1.fc20
Comment 4 Fedora Update System 2014-02-18 18:03:46 EST
virt-manager-1.0.0-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.0-2.fc20
Comment 5 Fedora Update System 2014-02-21 19:38:43 EST
Package virt-manager-1.0.0-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing virt-manager-1.0.0-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2789/virt-manager-1.0.0-2.fc20
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2014-02-28 13:25:11 EST
virt-manager-1.0.0-3.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/virt-manager-1.0.0-3.fc20
Comment 7 Fedora Update System 2014-03-04 01:46:42 EST
virt-manager-1.0.0-3.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.