Bug 1028243 - AttributeError: 'F18_Url' object has no attribute 'partition'
AttributeError: 'F18_Url' object has no attribute 'partition'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
abrt_hash:49ba6cff7f5e98cabdf9c060aac...
:
: 1040730 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 19:47 EST by Brian Lane
Modified: 2014-10-07 19:47 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-20.25.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-07 19:47:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (273.69 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: anaconda.log (7.93 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: environ (404 bytes, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: lsblk_output (1.88 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: nmcli_dev_list (4.33 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: os_info (291 bytes, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: program.log (37.60 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: storage.log (84.08 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: syslog (64.85 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: ifcfg.log (650 bytes, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details
File: packaging.log (32.76 KB, text/plain)
2013-11-07 19:47 EST, Brian Lane
no flags Details

  None (edit)
Description Brian Lane 2013-11-07 19:47:12 EST
Description of problem:
passed askmethod, selected iso, returned to source and selected closest mirror.

Version-Release number of selected component:
anaconda-20.25.6-1

The following was filed automatically by anaconda:
anaconda 20.25.6-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 53, in __getattr__
    return getattr(self.handler.url, name)
  File "/usr/lib/python2.7/site-packages/pykickstart/commands/method.py", line 102, in __getattr__
    return FC3_Method.__getattr__(self, name)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 416, in _method_changed
    if old_source.method == "harddrive" and old_source.partition:
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/source.py", line 479, in changed
    method_changed = self._method_changed()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 127, in _runSpoke
    if action.changed and (not action.skipTo or (action.skipTo and action.applyOnSkip)):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/hubs/__init__.py", line 424, in _on_spoke_clicked
    self._runSpoke(spoke)
AttributeError: 'F18_Url' object has no attribute 'partition'

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2020-Beta\x20x86_64  askmethod BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.11.6-301.fc20.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        20-Beta
Comment 1 Brian Lane 2013-11-07 19:47:17 EST
Created attachment 821356 [details]
File: anaconda-tb
Comment 2 Brian Lane 2013-11-07 19:47:20 EST
Created attachment 821357 [details]
File: anaconda.log
Comment 3 Brian Lane 2013-11-07 19:47:23 EST
Created attachment 821358 [details]
File: environ
Comment 4 Brian Lane 2013-11-07 19:47:26 EST
Created attachment 821359 [details]
File: lsblk_output
Comment 5 Brian Lane 2013-11-07 19:47:28 EST
Created attachment 821360 [details]
File: nmcli_dev_list
Comment 6 Brian Lane 2013-11-07 19:47:31 EST
Created attachment 821361 [details]
File: os_info
Comment 7 Brian Lane 2013-11-07 19:47:34 EST
Created attachment 821362 [details]
File: program.log
Comment 8 Brian Lane 2013-11-07 19:47:38 EST
Created attachment 821363 [details]
File: storage.log
Comment 9 Brian Lane 2013-11-07 19:47:41 EST
Created attachment 821364 [details]
File: syslog
Comment 10 Brian Lane 2013-11-07 19:47:44 EST
Created attachment 821365 [details]
File: ifcfg.log
Comment 11 Brian Lane 2013-11-07 19:47:47 EST
Created attachment 821366 [details]
File: packaging.log
Comment 12 Chris Lumens 2014-01-02 11:05:48 EST
*** Bug 1040730 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.