Bug 1028244 - hwcert-client tries to install kabi-whitelists for the info tests, but RHEL 6.5 renamed the package
hwcert-client tries to install kabi-whitelists for the info tests, but RHEL 6...
Status: CLOSED ERRATA
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.6.5
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Brian Brock
:
: 1028611 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-07 19:50 EST by Greg Nichols
Modified: 2013-11-21 19:08 EST (History)
6 users (show)

See Also:
Fixed In Version: hwcert-client 1.6.5-25.1
Doc Type: Bug Fix
Doc Text:
Cause: kabi-whitelist was renamed in RHEL6.5 to kernel-abi-whitelist. This package name changed is handled via yum and rpm with a %obsoletes and %provides kabi-whitelist to ensure the correct upgrade path works, however the hwcert-client test suite checks only the rpm name so it did not follow this. Consequence: All runs of the info test in the hwcert-client test suite will prompt the user that kabi-whitelist is not installed and ask if they want to attempt to install it. This will always fail to install as the kabi-whitelist package has been replaced. So the user will continue to receive this problem. After pressing No the info test will properly review the abi when necessary and pass/fail correctly. Fix: The runtime requires in the info test for the kabi-whitelist package name has been removed and a clear error message has been added when the whitelist cannot be located. Result: Info runs that do not require the whitelist will work correctly and never prompt the user to install the whitelist package. Info runs that require the whitelist but do not have it installed will inform the user that they need to install it and then fail the info test. Info runs that require the whitelist but do have it installed will correctly perform the abi comparison and pass/fail as appropriate.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 05:01:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info patch on 1.6.5-31 to remove kernal abi package installation (1.51 KB, patch)
2013-11-07 21:08 EST, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-11-07 19:50:20 EST
Description of problem:

The info test does a kernel ABI whitelist test for non-Red-Hat modules.  For this, it attempts to install kabi-whitelists in the planning phase.  RHEL 6.5 renamed this package to kernel-abi-whitelists.   Since kernel-abi-whitelists has a %provides kabi-whitelists, the whitelists are installed, but hwcert-client prints an error every re-planning phase because it checks for the package using "rpm -q kabi-whitelists".


Version-Release number of selected component (if applicable):

hwcert-client 1.6.5-25
Comment 3 Greg Nichols 2013-11-07 21:08:51 EST
Created attachment 821413 [details]
info patch on 1.6.5-31 to remove kernal abi package installation
Comment 7 errata-xmlrpc 2013-11-13 05:01:41 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1515.html
Comment 8 Greg Nichols 2013-11-21 19:08:00 EST
*** Bug 1028611 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.