Bug 1028284 - Should not create a medium gear in small node by adding cartridge with NODE_PROFILE enable.
Should not create a medium gear in small node by adding cartridge with NODE_P...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
All All
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 00:48 EST by zhaozhanqi
Modified: 2015-05-14 19:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:29:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhaozhanqi 2013-11-08 00:48:11 EST
Description of problem:
Given a small scaling app created. Add a medium gear db cartridge for this app by restapi. It will return error: No nodes available. If the problem persists please contact Red Hat support. But actually, the DB medium gear has been created in the small node. Thus some operation like 'rhc app show $app" or 'rhc domain show' will be blocked with error "Unable to complete the requested operation due to: No nodes available. If the problem persists please contact Red Hat support. 
Reference ID: ab6cf774b9c919554b845afb40ed9a4f"

the multi-node env condition is:
1. enable the NODE_PROFILE
2. no medium node.

Version-Release number of selected component (if applicable):
devenv_4003

How reproducible:
always

Steps to Reproduce:
1. Create multi-node env(1 district include 2 small node) and make sure NO medium node.
2. Enable the NODE_PROFILE in /etc/openshift/plugins.d/openshift-origin-msg-broker-mcollective-dev.conf
  NODE_PROFILE_ENABLED=true
3. Create one small scalable app
   rhc app create zqphps php-5.3 -s
4. Add one medium mysql-5.3 db cartridge by restapi
  curl -s -k -H Content-Type:application/json -u user:pass https://instance/broker/rest/domains/zqd/applications/zqphps/cartridges -X POST -d '{"name":"mysql-5.1","gear_size":"medium"}'
5. rhc domain show

Actual results:
step 4:
will be show error:
No nodes available. If the problem persists please contact Red Hat support
but in fact, the medium gear has been created in one node

 694234410245577689268224]# ls
app-deployments  app-root  mysql

step 5:
rhc domain show
Unable to complete the requested operation due to: No nodes available. If the problem persists please contact Red Hat support. 
Reference ID: ab6cf774b9c919554b845afb40ed9a4f

Expected results:
This medium gear should not be created and rhc domain show 

Additional info:
if create an app with medium gear on NO medium node env,it won't create a gear in node.
Comment 1 zhaozhanqi 2013-11-08 01:19:50 EST
In addition, the following situation should be same issue.

After adding one medium node, and then adding a medium db cartridge to small scalable app, the medium db gear still be created on small node. It should be created on medium node since gear_profile enable.
Comment 2 Abhishek Gupta 2013-11-08 17:42:15 EST
Fixed with --> https://github.com/openshift/origin-server/pull/4139
Comment 4 zhaozhanqi 2013-11-10 22:24:47 EST
tested this bug on devenv_4016

It still can create medium gear on small node while enable gear_profile and no medium node existing. In my opinion, it should return error, like ‘No nodes available’
Comment 5 Abhishek Gupta 2013-11-11 14:33:09 EST
Tried it on devenv_4017 but could not reproduce this. Please provide me with an environment where this is reproducible and I will try it out.
Comment 6 zhaozhanqi 2013-11-11 22:25:47 EST
Retested this issue on devenv_4018, it can not be reproduced. thx
  mark it as verified.

Note You need to log in before you can comment on or make changes to this bug.