Bug 1028299 - Dist-geo-rep : geo-rep is skipps all the changelogs and doesn't sync any files to slave.
Dist-geo-rep : geo-rep is skipps all the changelogs and doesn't sync any file...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: geo-replication (Show other bugs)
2.1
x86_64 Linux
high Severity urgent
: ---
: ---
Assigned To: Venky Shankar
Vijaykumar Koppad
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 01:56 EST by Vijaykumar Koppad
Modified: 2014-08-24 20:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.42rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-27 10:46:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaykumar Koppad 2013-11-08 01:56:01 EST
Description of problem: geo-rep is skipping all the changelogs saying "skipping already processed change" and not syncing any files to slave.

geo-rep logs 
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[2013-11-08 11:39:02.62906] I [master(/bricks/brick1):437:crawlwrap] _GMaster: 20 crawls, 0 turns
[2013-11-08 11:39:38.889159] I [master(/bricks/brick1):1019:crawl] _GMaster: skipping already processed change: CHANGE
LOG.1383890977...
[2013-11-08 11:39:53.945113] I [master(/bricks/brick1):1019:crawl] _GMaster: skipping already processed change: CHANGE
LOG.1383890992...
[2013-11-08 11:40:02.965471] I [master(/bricks/brick1):437:crawlwrap] _GMaster: 20 crawls, 0 turns
[2013-11-08 11:40:08.994954] I [master(/bricks/brick1):1019:crawl] _GMaster: skipping already processed change: CHANGE
LOG.1383891007...
[2013-11-08 11:40:24.49969] I [master(/bricks/brick1):1019:crawl] _GMaster: skipping already processed change: CHANGEL
OG.1383891022...
[2013-11-08 11:40:39.99138] I [master(/bricks/brick1):1019:crawl] _GMaster: skipping already processed change: CHANGEL
OG.1383891037...
[2013-11-08 11:41:03.161604] I [master(/bricks/brick1):437:crawlwrap] _GMaster: 20 crawls, 0 turns
[2013-11-08 11:42:04.825397] I [master(/bricks/brick1):437:crawlwrap] _GMaster: 20 crawls, 0 turns

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Version-Release number of selected component (if applicable):glusterfs-3.4.0.40rhs-1


How reproducible:Happens everytime


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave. 
2.create some data on master
3.check if it syncs to slave. 

Actual results:It skips all the changelogs and doesn't sync any files to slaves.  


Expected results: syncing is what geo-rep should do.


Additional info:
Comment 2 Avra Sengupta 2013-11-08 02:34:49 EST
https://code.engineering.redhat.com/gerrit/#/c/15403/

This was due to a unary to tuple comparison which resulted in changelogs getting skipped.
Comment 3 Vijaykumar Koppad 2013-11-12 03:39:35 EST
Verified on glusterfs-3.4.0.42rhs-1, works fine.
Comment 4 errata-xmlrpc 2013-11-27 10:46:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1769.html

Note You need to log in before you can comment on or make changes to this bug.