Bug 1028306 - Somtimes win8-32 guest( with "-vga qxl/std") display with no color after boot up
Somtimes win8-32 guest( with "-vga qxl/std") display with no color after boo...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 02:08 EST by langfang
Modified: 2014-07-02 03:50 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 03:50:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description langfang 2013-11-08 02:08:38 EST
Description of problem:

Somtimes win8-32 guest display with no colour after boot  up

Version-Release number of selected component (if applicable):
Host
# uname -r
2.6.32-429.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.415.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-28.el6.x86_64
Guest
win8-32


How reproducible:

10%

Steps to Reproduce:
1.Boot guest 
...-spice port=8000,disable-ticketing -vga qxl/std...

2.After guest boot up


Actual results:

After boot up guest display with no colour .

Expected results:

Guest should show normally and with color.

Additional info:


1) Tried use "-vga cirrus" about 10 times , not hit
2) My CLI:

 /usr/libexec/qemu-kvm -cpu Penryn -M rhel6.5.0 -enable-kvm -m 4096 -smp 2s=2,cores=1,threads=1 -name win8-32 -uuid 36e0dd8a-dd81-4498-8f66-34d0f035e9c6 -nodefconfig -nodefaults -monitor stdio -rtc base=utc -device piix3-usb-uhci,id=usb,bus=pci.0,addr=0x1.0x2 -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x7 -drive file=/media/win8-32-install6.5-host.qcow2,if=none,id=drive-virtio-disk0,format=qcow2,cache=none -device virtio-blk-pci,scsi=off,bus=pci.0,addr=0x5,drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive file=/usr/share/virtio-win/virtio-win.iso,if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=raw -device ide-drive,bus=ide.1,unit=1,drive=drive-ide0-1-0,id=ide0-1-0 -device usb-tablet,id=input0 -device intel-hda,id=sound0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x6 -drive file=/media/test.qcow2,format=qcow2,if=none,id=drive-ide0-0-0,werror=stop,rerror=stop,cache=none -device virtio-blk-pci,drive=drive-ide0-0-0,id=ide0-0-0,addr=0x9 -netdev tap,id=hostnet0,script=/etc/qemu-ifup -device virtio-net-pci,ctrl_guest_offloads=on,netdev=hostnet0,mac=00:10:20:2d:31:21,bus=pci.0,addr=0x8,id=net0 -spice port=8000,disable-ticketing -vga qxl -global PIIX4_PM.disable_s3=0 -global PIIX4_PM.disable_s4=0
Comment 2 RHEL Product and Program Management 2013-11-11 03:05:36 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 3 Gerd Hoffmann 2014-04-17 04:11:26 EDT
Can you attach a screenshot?
Do you have qxl guest drivers installed in the guest?  If so, which version?
Comment 4 Qunfang Zhang 2014-04-17 04:47:25 EDT
Hi, Maosheng

Could you give a help to test this bug and reply Gerd's comment 3 as flang is taking leave? 

Thanks,
Qunfang
Comment 5 huiqingding 2014-04-23 23:01:17 EDT
I use the command line of comment 0 to boot a win8-32 guest for 10 times and not hit this issue.

Version-Release number of selected component (if applicable):
Host
# uname -r
2.6.32-459.el6.x86_64
# rpm -q qemu-kvm
qemu-kvm-0.12.1.2-2.424.el6.x86_64
# rpm -q seabios
seabios-0.6.1.2-28.el6.x86_64
Guest
win8-32
Comment 6 Gerd Hoffmann 2014-05-07 06:37:17 EDT
Ping?  Any news?  See comment #3 question.
If it doesn't reproduce any more (comment #5) I'll go close it as notabug.
Comment 7 Qunfang Zhang 2014-05-07 06:57:05 EDT
(In reply to Gerd Hoffmann from comment #6)
> Ping?  Any news?  See comment #3 question.
> If it doesn't reproduce any more (comment #5) I'll go close it as notabug.

Hi, Gerd

flang is taking leave these months and Huiqing helped re-test comment 3 but could not reproduce this issue.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.