Bug 1028322 - Change Test Plan State will destroy all mapping
Change Test Plan State will destroy all mapping
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5.2
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: hwcert-catalog
:
Depends On:
Blocks: 1032345
  Show dependency treegraph
 
Reported: 2013-11-08 03:27 EST by Yunlong Xue
Modified: 2013-11-26 19:13 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-26 19:13:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yunlong Xue 2013-11-08 03:27:54 EST
In new version cert(cert which use Hardware Layer), change "Test Plan State " will make all mapping disappear.


Steps to Reproduce:
1.maps some results in plan
2.change "Test Plan State" to "Melted"
3.change "Test Plan State" back to "Frozen"

Then all mappings are disappear.
Comment 1 Rob Landry 2013-11-08 19:27:04 EST
Will they reappear with show.cgi or they are truly lost?
Comment 5 Huan Zhang 2013-11-21 03:21:01 EST
(In reply to Damian Jansen from comment #4)
> rlandy - I'm not even sure what the problem is. "Map some results in plan"
> is about as vague as it could be. I'd need more info about this problem
> before I can estimate it.

How to reproduce:
1) create cert/spec with testplan by following the steps in bz1028885
2) go the the cert page
3) click review tab
4) change the state of the test plan to Melted and save
5) change the state of the test plan back to Frozen
6) go to the advanced tab to check if the value of "Hardware Specification" in the relation ships section is disappeared.
Comment 6 Huan Zhang 2013-11-21 03:21:23 EST
test passed on web2
Comment 7 Huan Zhang 2013-11-21 03:29:13 EST
Sorry, I *misunderstood* this bug. Please ignore Comment 5 and comment 6!
Comment 9 Huan Zhang 2013-11-21 03:59:39 EST
How to reproduce:
1) create cert/spec with testplan by following the steps in bz1028885
2) go to the cert page
3) click review tab
4) create test plans and freeze them
5) click *confirmed* and save test plans
Please note:
The map is between each testplan and its confirmed status
6) change the status of test plan to melted
7) change the test plan description and save
8) freeze the test plans
9) check if the maps are still there
Comment 10 Huan Zhang 2013-11-21 03:59:58 EST
verified on web2
Comment 11 Wei Shen 2013-11-26 01:39:54 EST
verified on partner
Comment 12 Feng Wang 2013-11-26 02:36:55 EST
tested and verified on parter
Comment 13 Tony Fu 2013-11-26 19:13:01 EST
verified on live

Note You need to log in before you can comment on or make changes to this bug.