Bug 1028371 - xmvn: Unsatisfied bouncycastle requires when version is specified
xmvn: Unsatisfied bouncycastle requires when version is specified
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xmvn (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislav Ochotnicky
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 1030978
  Show dependency treegraph
 
Reported: 2013-11-08 05:09 EST by Marek Goldmann
Modified: 2013-11-15 08:04 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-15 08:04:09 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Goldmann 2013-11-08 05:09:22 EST
Description of problem:

Update of truezip on Fedora 20 fails with following message:

--> Package jetty-plus.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-proxy.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-rewrite.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-servlets.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-websocket-api.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-websocket-common.noarch 0:9.0.5-1.fc20 will be installed
---> Package jetty-websocket-server.noarch 0:9.0.5-1.fc20 will be installed
--> Processing Dependency: mvn(org.eclipse.jetty.websocket:websocket-client) = 9.0.5.v20130815 for package: jetty-websocket-server-9.0.5-1.fc20.noarch
---> Package jetty-websocket-servlet.noarch 0:9.0.5-1.fc20 will be installed
---> Package maven-remote-resources-plugin.noarch 0:1.4-5.fc20 will be installed
--> Processing Dependency: plexus-resources for package: maven-remote-resources-plugin-1.4-5.fc20.noarch
--> Processing Dependency: maven-plugin-annotations for package: maven-remote-resources-plugin-1.4-5.fc20.noarch
--> Processing Dependency: maven-filtering for package: maven-remote-resources-plugin-1.4-5.fc20.noarch
--> Processing Dependency: maven-common-artifact-filters for package: maven-remote-resources-plugin-1.4-5.fc20.noarch
--> Processing Dependency: maven-artifact-resolver for package: maven-remote-resources-plugin-1.4-5.fc20.noarch
---> Package opensaml-java-xmltooling.noarch 0:1.3.4-7.fc20 will be installed
--> Processing Dependency: mvn(ca.juliusdavies:not-yet-commons-ssl) for package: opensaml-java-xmltooling-1.3.4-7.fc20.noarch
---> Package plexus-io.noarch 0:2.0.5-8.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
---> Package xom.noarch 0:1.0-14.fc20 will be installed
--> Running transaction check
---> Package apache-commons-jexl.noarch 0:2.1.1-8.fc20 will be installed
---> Package apache-commons-jxpath.noarch 0:1.3-17.fc20 will be installed
---> Package apache-commons-vfs.noarch 0:2.0-11.fc20 will be installed
---> Package jetty-websocket-client.noarch 0:9.0.5-1.fc20 will be installed
---> Package maven-artifact-resolver.noarch 1:1.0-9.fc20 will be installed
---> Package maven-common-artifact-filters.noarch 0:1.4-11.fc20 will be installed
---> Package maven-filtering.noarch 0:1.1-2.fc20 will be installed
---> Package maven-plugin-annotations.noarch 0:3.1-14.fc20 will be installed
--> Processing Dependency: maven-plugin-tools = 3.1-14.fc20 for package: maven-plugin-annotations-3.1-14.fc20.noarch
---> Package not-yet-commons-ssl.noarch 0:0.3.11-10.fc20 will be installed
---> Package plexus-resources.noarch 0:1.0-0.14.a7.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Running transaction check
---> Package maven-plugin-tools.noarch 0:3.1-14.fc20 will be installed
---> Package truezip-driver-zip.noarch 0:7.6.6-6.fc20 will be installed
--> Processing Dependency: mvn(org.bouncycastle:bcprov-jdk16:1.46) for package: truezip-driver-zip-7.6.6-6.fc20.noarch
--> Finished Dependency Resolution
Error: Package: truezip-driver-zip-7.6.6-6.fc20.noarch (updates-testing)
           Requires: mvn(org.bouncycastle:bcprov-jdk16:1.46)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest


But it seems that the bouncycastle has correct provides:

mvn(org.bouncycastle:bcprov-jdk16) = 1.46

And the requirement:

mvn(org.bouncycastle:bcprov-jdk16:1.46)

should be satisfied, but it's not:

$ repoquery --repoid fedora --releasever 20 --whatprovides 'mvn(org.bouncycastle:bcprov-jdk16:1.46)'

[result is empty]

Requirement without version resolves correctly:

$ repoquery --repoid fedora --releasever 20 --whatprovides 'mvn(org.bouncycastle:bcprov-jdk16)'
bouncycastle-0:1.46-11.fc21.noarch
Comment 1 Stanislav Ochotnicky 2013-11-15 08:04:09 EST
This is not a bug in XMvn. truezip-7.6.6-6.fc20 has been built with bouncycastle-1.46-10.fc20 in buildroot. That resulted in XMvn generating compat requires on bouncycastle since that version of bouncycastle had versioned jar files (a bug since it's not a compat package).

truezip needs to be rebuilt with bouncycastle-1.46-11.fc20 in buildroots for this to be fixed. Seems that latest f20 build of truezip failed due to missing BRs. I guess that might be the problem

Note You need to log in before you can comment on or make changes to this bug.