Bug 1028532 - No entering graphical target
No entering graphical target
Status: CLOSED DUPLICATE of bug 1028718
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 12:18 EST by rvcsaba
Modified: 2013-11-11 05:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 05:42:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rvcsaba 2013-11-08 12:18:46 EST
Description of problem:

I installed selinux-policy-3.12.1-74.12.fc19, reboot my machine, and can't start lightdm and Xorg. If I downgrade to selinux-policy-3.12.1-74.11.fc19, my computer work correctly.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Lars S. Jensen 2013-11-10 06:27:14 EST
It is also gdm that has problems.
startx is working.

Reproduced: reboot and not login screen.

Workaround is to run startx from a VT login if .xinit is correct configured.

fix: yum downgrade selinux-policy selinux-policy-mls selinux-policy-targeted


Some logs:
> systemctl status lightdm.service 
lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled)
   Active: failed (Result: start-limit) since Sun 2013-11-10 11:44:03 CET; 27min ago
     Docs: man:lightdm(1)
  Process: 1147 ExecStart=/usr/sbin/lightdm (code=exited, status=1/FAILURE)

journalctl -x
Nov 10 09:47:49 saxon2.lasj.home lightdm[1539]: Failed to use bus name org.freedesktop.DisplayManager, do you have appropriate permissions?
Nov 10 09:47:49 saxon2.lasj.home systemd[1]: lightdm.service: main process exited, code=exited, status=1/FAILURE
Nov 10 09:47:49 saxon2.lasj.home systemd[1]: Failed to start Light Display Manager.
Comment 2 Lars S. Jensen 2013-11-10 06:49:27 EST
here is the audit.log entry:
type=USER_AVC msg=audit(1384080243.578:496): pid=492 uid=81 auid=4294967295 ses=4294967295  subj=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 msg='avc:  denied  { acquire_svc } for service=org.freedesktop.DisplayManager spid=1147 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:system_r:system_dbusd_t:s0-s0:c0.c1023 tclass=dbus  exe="/usr/bin/dbus-daemon" sauid=81 hostname=? addr=? terminal=?'type=SERVICE_START msg=audit(1384080243.583:497): pid=1 uid=0 auid=4294967295 ses=4294967295  subj=system_u:system_r:init_t:s0 msg=' comm="lightdm" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=failed'
Comment 3 Miroslav Grepl 2013-11-11 05:42:40 EST

*** This bug has been marked as a duplicate of bug 1028718 ***

Note You need to log in before you can comment on or make changes to this bug.