Bug 1028551 - jansi-native: doesn't install attached artifacts with proper classifiers
jansi-native: doesn't install attached artifacts with proper classifiers
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: jansi-native (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Stanislav Ochotnicky
Jan Kepler
: Patch
Depends On:
Blocks: 1028540
  Show dependency treegraph
 
Reported: 2013-11-08 13:39 EST by Stanislav Ochotnicky
Modified: 2014-06-18 03:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: 1.4-8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1028550
Environment:
Last Closed: 2014-06-13 05:18:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch (1.54 KB, patch)
2014-01-22 15:04 EST, Mikolaj Izdebski
no flags Details | Diff

  None (edit)
Description Stanislav Ochotnicky 2013-11-08 13:39:31 EST
+++ This bug was initially created as a clone of Bug #1028550 +++

Description of problem:
If current version of jansi-native is rebuilt it will produce incomplete RPMs due to attached artifacts with "linux<bits>" classifiers not being installed. This can be fixed by adding following line to %prep:

%mvn_package :::linux%{bits}: __default

Version-Release number of selected component (if applicable):
jansi-native-1.5-1.fc21

How reproducible:
always

Steps to Reproduce:
1. rebuild package in current rawhide
2. look at rpm provides
3. notice missing linux64/linux32 mvn() provides

Actual results:
missing architecture mvn() provides

Expected results:
mvn(org.fusesource.jansi:jansi-native::linux64:) = 1.4
or
mvn(org.fusesource.jansi:jansi-native::linux32:) = 1.4

provides generated
Comment 4 Mikolaj Izdebski 2014-01-22 15:04:45 EST
Created attachment 854021 [details]
Proposed patch
Comment 5 Ludek Smid 2014-06-13 05:18:34 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.