Bug 1028558 - [RHSC] Not working: "rhsc-config -s AdminPassword=<your_password> "
[RHSC] Not working: "rhsc-config -s AdminPassword=<your_password> "
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dusmant
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 14:03 EST by Matt Mahoney
Modified: 2016-02-17 19:15 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 11:38:53 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Mahoney 2013-11-08 14:03:55 EST
Description of problem:
on the RHSC server, the following command does not work
(From Doc section: B.1. Changing Password for the Administrative User)

"rhsc-config -s AdminPassword=<your_password>"

Example: 
rhsc-config -s AdminPassword=aNewPassword
Cannot set value aNewPassword to key AdminPassword.

Version-Release number of selected component (if applicable):
CB6

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
Should not result in message "Cannot set value..."

Additional info:
Comment 2 Dusmant 2013-11-09 04:59:27 EST
Matt, is this through CLI or through REST API?
Comment 3 Prasanth 2013-11-11 04:24:57 EST
This was a definitely a doc bug in 2.1 RC guide but looks like this got fixed in the official 2.1 doc. 

Please refer: https://access.redhat.com/site/documentation/en-US/Red_Hat_Storage/2.1/html-single/Console_Administration_Guide/index.html#Password_Appendix

--------------------
[root@rhs-client3 ~]# rhsc-config -s AdminPassword=interactive
Please enter a password: 
Please reenter password: 
[root@rhs-client3 ~]# /etc/init.d/ovirt-engine restart
Stopping oVirt Engine:                                     [  OK  ]
Starting oVirt Engine: 
--------------------
Comment 4 Dusmant 2013-11-11 09:35:38 EST
Matt and Prasanth,
    This does not seem like a bug. Let me know, if you think otherwise.

-Dusmant

Note You need to log in before you can comment on or make changes to this bug.