Bug 1028591 - packstack generates invalid configuration when using GRE tunnels
packstack generates invalid configuration when using GRE tunnels
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Grizzly
Assigned To: RHOS Maint
Ofer Blaut
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 15:06 EST by Lars Kellogg-Stedman
Modified: 2016-03-30 19:03 EDT (History)
5 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.1.1-0.31.dev696.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:03:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lars Kellogg-Stedman 2013-11-08 15:06:57 EST
With openstack-packstack openstack-packstack-2013.1.1-0.29.dev683.el6.noarch and the following in a packstack answers file:

  CONFIG_QUANTUM_L2_PLUGIN=openvswitch
  CONFIG_QUANTUM_OVS_TENANT_NETWORK_TYPE=gre

The generated /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini
has an OVS section that looks like this:

  [OVS]
  tunnel_id_ranges=1:1000
  integration_bridge=br-int
  tenant_network_type=gre
  enable_tunneling=False

With enable_tunneling=False, this causes the quantum-server to throw
an error and refuse to start.

This has been fixed in more recent revisions of the "grizzly" branch
in the packstack repository (45b92dee9b1e4a29a6e442d20ba1150ab4625584).
Comment 2 Martin Magr 2013-11-11 07:44:47 EST
I changed this bug to RHOS specific thinking it's not fixed yet. I was wrong. Changing product back. Sorry for that.

Note You need to log in before you can comment on or make changes to this bug.