Bug 102860 - Run dialog box shortcut is being ignored
Run dialog box shortcut is being ignored
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: gnome-desktop (Show other bugs)
1.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-21 18:26 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version: control-center-2.3.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 13:11:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-08-21 18:26:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030722 Galeon/1.3.7

Description of problem:
Prior to upgrading to pre-release Gnome 2.4 packages, I had "ALT+R" bound so
that Gnome would produce the Run dialog box.  Upon upgrading, I found that ALT+R
does nothing except emit a beep.  I have changed the shortcut to multiple
different combinations/keys (F4, META+R, etc.) - all of which are ignored.

If I switch to a terminal and press the shortcut, I should not see the
characters appear in the terminal.  Instead, Gnome allows the keys to go through
as if they were not properly captured.

See additional information for a list of packages (and revisions).  I noticed
that "gnome-keybinding-properties" applet is contained within the control-center
package which has a version of "2.2.2" (supporting the Gnome 2.2 desktop).



Version-Release number of selected component (if applicable):
gnome-desktop-2.3.6.1-1

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to pre-Gnome 2.4 packages from Rawhide.
2. Go to Preferences->Keyboard Shortcuts
3. Assign a key combination to open the "Run" dialog box.
4. Close Shortcuts preferences dialog box and enter your combination.
    

Actual Results:  Combination is ignored, and the dialog box does not pop up.

Expected Results:  Combination is recognized by Gnome magic, and the Run dialog
box should appear.

Additional info:

control-center-2.2.2-1
libgnome-2.3.6-1
Comment 1 Michael Lee Yohe 2003-08-22 11:25:04 EDT
Another oddity...

Just browsing the bugs and found Bug 102801 where Tim Waugh references opening
the Run dialog box with ALT+F2.  Out of curiosity, I type in ALT+F2, and voila -
the Run dialog box appears.

Now, why can't it be rebound to something else (especially since the applet says
it's bound to something else)... there lies the mystery.
Comment 2 Michael Lee Yohe 2003-08-26 13:11:09 EDT
Upgrading control-center-2.3.5-1 fixed the problem.

Note You need to log in before you can comment on or make changes to this bug.