Bug 1028633 - The utility oo-devel-node app-create shouldn't restrict the order
The utility oo-devel-node app-create shouldn't restrict the order
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Dan McPherson
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 17:28 EST by Peter Ruan
Modified: 2015-05-14 19:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-29 19:50:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Ruan 2013-11-08 17:28:11 EST
Description of problem:
  The order of the argument matters when running oo-devel-node app-create.  Why should it?

Version-Release number of selected component (if applicable):
current

How reproducible:
always.

Steps to Reproduce:
1. oo-devel-node app-create --with-namespace case247269 --with-app-name case247269 --with-app-uuid 999999999999999999999999 --with-container-uuid 999999999999999999999999
2.
3.

Actual results:
[0mMissing --with-container-uuid UUID

Usage: oo-devel-node app-create --with-container-uuid UUID --with-namespace NAMESPACE \
--with-app-uuid UUID --with-app-name NAME --with-secret-token TOKEN \
[--with-uid UID] [--with-container-name NAME] \
[--with-quota-blocks BLOCKS] [--with-quota-files FILES] 

Expected results:
order of the argument shouldn't matter.

Additional info:
Comment 1 Dan McPherson 2014-01-20 12:29:28 EST
https://github.com/openshift/origin-server/pull/4524

This seems to be the default behavior of commander and the use case isn't interesting enough to work around.  I added a better error message but not going to make another change to fix fully.
Comment 3 chunchen 2014-01-20 22:11:04 EST
It's fixed, verified on devenv_4247, please refer to the following results:

# oo-devel-node app-create --with-namespace case247269 --with-app-name case247269 --with-app-uuid 999999999999999999999999 --with-container-uuid 999999999999999999999999

Missing --with-container-uuid UUID as the first option

Usage: oo-devel-node app-create --with-container-uuid UUID --with-namespace NAMESPACE \
     --with-app-uuid UUID --with-app-name NAME --with-secret-token TOKEN \
     [--with-uid UID] [--with-container-name NAME] \
     [--with-quota-blocks BLOCKS] [--with-quota-files FILES]

Note You need to log in before you can comment on or make changes to this bug.