Bug 1028646 - Error: json: cannot unmarshal number into Go value of type string
Error: json: cannot unmarshal number into Go value of type string
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: docker-io (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Lokesh Mandvekar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 21:43 EST by Nathan W
Modified: 2014-07-01 18:59 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-23 19:39:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan W 2013-11-08 21:43:53 EST
Description of problem:

[root@wyrd ~]# docker search centos
2013/11/08 18:38:41 Error: json: cannot unmarshal number into Go value of type string

[root@wyrd ~]# docker search base
2013/11/08 18:43:24 Error: json: cannot unmarshal number into Go value of type string

Version-Release number of selected component (if applicable):

docker-io-0.7-0.13.dm.fc20.x86_64

How reproducible:
every time

Steps to Reproduce:
1. install docker-io-0.7-0.13.dm.fc20.x86_64
2. search for an image

Actual results:

Error: json: cannot unmarshal number into Go value of type string

Expected results:
list of available image

Additional info:
Comment 1 Lokesh Mandvekar 2013-11-13 11:33:54 EST
looks like 0.7-rc5 shoud fix this: https://github.com/dotcloud/docker/issues/2359

Note You need to log in before you can comment on or make changes to this bug.