Bug 1028648 - Keep resubscribing to unsubscribed folders over IMAP
Keep resubscribing to unsubscribed folders over IMAP
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-08 23:24 EST by Peter Baumgarten
Modified: 2013-11-20 04:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-17 18:05:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Baumgarten 2013-11-08 23:24:57 EST
Description of problem:
I have two folders in my IMAP email account that I do not want to subscribe to in evolution. One is called SMS and one is called Call log. Every time I select unsubscribe on these folders they will be re-subscribed when I close evolution and then re-open evolution. After I re-open evolution then the folders are re-subscribed to.

Version-Release number of selected component (if applicable):
3.8.5

How reproducible:
Every time

Steps to Reproduce:
1. Unsubscirbe from SMS and Call log
2. Close evolution
3. Re-open evolution

Actual results:
Folders are re-subscribed to

Expected results:
Folders are not subscribed to

Additional info:
The IMAP server is on a debian 7 machine running dovecot 2.1.7-7

The roundcube (www.roundcube.net) client does not have this problem. Not being snarky, just another IMAP client pointing to the same server, same account. I do not think it is server side but client side.
Comment 1 Milan Crha 2013-11-11 04:37:30 EST
Thanks for a bug report. It's weird, because subscribed folder list is managed by the server, at least on IMAP. Could you go to account Properties and check whether Receiving Options tab has set "Show only subscribed folders" for the account? It doesn't explain if the folder is truly re-subscribed on its own, but it might help. Another test would be to run debugging for your IMAP account and see whether the unsubscribe succeeded for you. If you've the account configured as IMAP+, then run evolution like this:
   $ CAMEL_DEBUG=imapx evolution
which will print what the IAMP+ account does.
Comment 2 Peter Baumgarten 2013-11-17 18:05:28 EST
Checking that check box in Receiving options did it. It was showing all folders regardless of whether I was subscribed to it or not. Once "Show only subscribed folders" was enabled the problem went away. Maybe it should be enabled by default? I never thought it was a server problem because I have two other clients K-9 mail and roundcube that did not have this issue. The "bug" has been fixed, this can be marked as closed.
Comment 3 Milan Crha 2013-11-20 04:32:35 EST
The default was changed to have the option unchecked, because there were many users with an opposite issue, they didn't see their folders, but they knew it's there. They simply didn't think of subscriptions.

Note You need to log in before you can comment on or make changes to this bug.