Bug 10287 - problem with the client socket of pump
problem with the client socket of pump
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pump (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Erik Troan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-21 14:04 EST by Julien Soula
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-04-20 11:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Julien Soula 2000-03-21 14:04:35 EST
hello,

I have some problem with pump program (pump-0.7.3) :

  # uname -a
  Linux kermadec 2.2.14 #3 Tue Mar 21 18:38:23 CET 2000 i586 unknown

At boot, the pump daemon is running and waiting on its socket.

   # ps auxwww | grep pump
   root        78  0.0  0.4  1480  520 ?        S    12:49   0:00
/sbin/pump -i eth0

   # netstat -p -a | grep pump
   unix  0      [ ACC ]     STREAM     LISTENING     27
78/pump             /var/run/pump.sock

But a pump client pretend that noone wait on socket and think it must
run as a daemon :

   # pump -s
   Operation failed.

   # ps auxwww | grep pump
   root        78  0.0  0.4  1480  520 ?        S    12:49   0:00
/sbin/pump -i eth0
   root       241  0.0  0.1   400  204 pts/0    S    12:51   0:00 pump -s


The most surprising is that the two daemons have both created the same
socket without errors :

   # netstat -p -a | grep pump
   unix  0      [ ACC ]     STREAM     LISTENING     27
78/pump             /var/run/pump.sock
   unix  0      [ ACC ]     STREAM     LISTENING     391
241/pump            /var/run/pump.sock

Despite that, the first daemon keep on doing its duty i.e. renewing
DHCP leases at good time.

Moreover, if it is killed and restarted then the client socket works
well.

PS: I've tried with kernel different socket options :

    Socket Filtering  (with/without)
    IP: TCP syncookie support (with/without)

 -- Julien
Comment 1 Julien Soula 2000-04-20 05:27:59 EDT
Sorry for the readers, this was not a bug, it was a stupid question!!!

I've checked many things inside the daemon but I've never checked if the
socket file existed (I though that yes since 'netstat' listed it).

In fact, a script, which clean various directories erased, the socket file.

So the bug report is off-topic.

Note You need to log in before you can comment on or make changes to this bug.