Bug 1028720 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'connectto' accesses on the unix_stream_socket @/tmp/dbus-SCHSE6Ei4S.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'connectto' acces...
Status: CLOSED DUPLICATE of bug 964651
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
20
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ef7c5295892ca0b848448ca3826...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 19:36 EST by ewickers
Modified: 2013-11-11 07:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 07:37:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ewickers 2013-11-09 19:36:03 EST
Description of problem:
Caused by installing ffmpeg
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'connectto' accesses on the unix_stream_socket @/tmp/dbus-SCHSE6Ei4S.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that totem-video-thumbnailer should be allowed connectto access on the dbus-SCHSE6Ei4S unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Objects                @/tmp/dbus-SCHSE6Ei4S [ unix_stream_socket ]
Source                        totem-video-thu
Source Path                   /usr/bin/totem-video-thumbnailer
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           totem-3.10.1-1.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-90.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.11.7-300.fc20.x86_64 #1 SMP Mon
                              Nov 4 15:07:39 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-11-09 19:27:41 EST
Last Seen                     2013-11-09 19:27:41 EST
Local ID                      b2feac6e-585b-469b-af8a-f70b0d7c0488

Raw Audit Messages
type=AVC msg=audit(1384043261.90:547): avc:  denied  { connectto } for  pid=3238 comm="totem-video-thu" path=002F746D702F646275732D53434853453645693453 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1384043261.90:547): arch=x86_64 syscall=connect success=no exit=EACCES a0=3 a1=7fff8c72b300 a2=17 a3=0 items=0 ppid=1468 pid=3238 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=1 tty=(none) comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: totem-video-thu,thumb_t,xdm_t,unix_stream_socket,connectto

Additional info:
reporter:       libreport-2.1.9
hashmarkername: setroubleshoot
kernel:         3.11.7-300.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-11-11 07:37:34 EST

*** This bug has been marked as a duplicate of bug 964651 ***

Note You need to log in before you can comment on or make changes to this bug.