Bug 1028723 - Default configuration refers to illegal PID_DIR
Default configuration refers to illegal PID_DIR
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: sysusage (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-09 21:29 EST by Frank Crawford
Modified: 2013-11-12 00:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-12 00:19:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
%description with some spelling fixes (1.46 KB, text/plain)
2013-11-11 11:15 EST, Zbigniew Jędrzejewski-Szmek
no flags Details

  None (edit)
Description Frank Crawford 2013-11-09 21:29:44 EST
Description of problem:
The shipped configuration file /etc/sysusage.cfg defines PID as "%{_localstatedir}/run", which is a non-existent directory, and is incorrect anyway.  Correct value should be "/run".

Version-Release number of selected component (if applicable):
sysusage-5.3-1.fc19.noarch

How reproducible:
100%

Steps to Reproduce:
1. Install sysusage RPM
2. View configuration file
3. Check variable PID_DIR

Actual results:
sysusage fails to run due to invalid PID directory.

Expected results:
Should be able to run sysusage programs.

Additional info:
Comment 1 Christopher Meng 2013-11-09 21:50:05 EST
I pushed -2 RPM yesterday which changed the PID to /var/run. Prior to that I made a typo in the spec:

http://pkgs.fedoraproject.org/cgit/sysusage.git/commit

I don't know why you want /run.
Comment 2 Frank Crawford 2013-11-09 23:27:37 EST
/var/run is fine as it links to /run, but I believe the latest standard with systemd is just to have a /run directory for everything.
Comment 3 Christopher Meng 2013-11-10 00:49:58 EST
I will ask a systemd developer to see if we really need to change this.

Thanks anyway.
Comment 4 Zbigniew Jędrzejewski-Szmek 2013-11-11 11:15:28 EST
Created attachment 822483 [details]
%description with some spelling fixes

In practice they are equivalent, but since /var/run is a compatibility symlink to /run, it is a bit nicer to use plain /run.

BTW. in the %description there are some typos, attempt at a patch attached.
Comment 5 Christopher Meng 2013-11-12 00:19:32 EST
(In reply to Zbigniew Jędrzejewski-Szmek from comment #4)
> Created attachment 822483 [details]
> %description with some spelling fixes
> 
> In practice they are equivalent, but since /var/run is a compatibility
> symlink to /run, it is a bit nicer to use plain /run.
> 
> BTW. in the %description there are some typos, attempt at a patch attached.

Thanks.

I will keep using /var/run (because too many packages are still using it and I don't see any better performance of using /run)

I just posted a tiny question:

https://lists.fedoraproject.org/pipermail/packaging/2013-November/009794.html

to see if any better solutions are available.

Note You need to log in before you can comment on or make changes to this bug.