Bug 102875 - up2date traceback when installing arjanv 2.6 kernel
up2date traceback when installing arjanv 2.6 kernel
Status: CLOSED DUPLICATE of bug 102804
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-22 00:36 EDT by Barry K. Nathan
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:58:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barry K. Nathan 2003-08-22 00:36:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703
Epiphany/0.8.4

Description of problem:
When I tried to upgrade from the severn 2.4.21-20.1.2024.2.1.nptl kernel to a
2.6 kernel, up2date failed with a traceback.

Version-Release number of selected component (if applicable):
up2date-3.9.10-2

How reproducible:
Always

Steps to Reproduce:
1. Make sure there are no 2.6 kernels already installed (may not be necessary,
but maybe it is).
2. Add the following line to /etc/sysconfig/rhn/sources:
yum 2.6testkernels http://people.redhat.com/arjanv/2.5/
3. Run "up2date -ui". (This assumes all other updates from your other existing
channels have already been installed.) UPDATE: Just "up2date kernel" also works.
4. Watch up2date download and install kernel (and possibly kernel-source,) then
explode near the end.
    

Actual Results:
Testing package set / solving RPM inter-dependencies...
########################################
url:
http://people.redhat.com/arjanv/2.5//RPMS.kernel/kernel-2.6.0-0.test3.1.31.i686.rpm
kernel-2.6.0-0.test3.1.31.i ########################## Done.
url:
http://people.redhat.com/arjanv/2.5//RPMS.kernel/kernel-source-2.6.0-0.test3.1.31.i386.rpm
kernel-source-2.6.0-0.test3 ########################## Done.
Preparing              ########################################### [100%]

Installing...
   1:kernel-source          ########################################### [100%]
   2:kernel                 ########################################### [100%]
WARNING: /lib/modules/2.6.0-0.test3.1.31/kernel/drivers/usb/media/stv680.ko
needs unknown symbol video_proc_entry
WARNING: /lib/modules/2.6.0-0.test3.1.31/kernel/drivers/usb/media/ov511.ko needs
unknown symbol video_proc_entry
WARNING: /lib/modules/2.6.0-0.test3.1.31/kernel/drivers/usb/media/se401.ko needs
unknown symbol video_proc_entry
WARNING: /lib/modules/2.6.0-0.test3.1.31/kernel/drivers/usb/media/usbvideo.ko
needs unknown symbol video_proc_entry
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 1147, in ?
    sys.exit(main() or 0)
  File "/usr/sbin/up2date", line 747, in main
    fullUpdate, dryRun=options.dry_run))
  File "/usr/sbin/up2date", line 1013, in batchRun
    batch.run()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 76, in run
    self.__installPackages()
  File "/usr/share/rhn/up2date_client/up2dateBatch.py", line 145, in
__installPackages
    self.kernelsToInstall = up2date.installPackages(self.packagesToInstall,
self.rpmCallback)
  File "/usr/share/rhn/up2date_client/up2date.py", line 719, in installPackages
    runPkgSpecialCases(pkgList)
  File "/usr/share/rhn/up2date_client/up2date.py", line 769, in runPkgSpecialCases
    apply(packageProvidesMethods[provideName], providesPackages[provideName])
TypeError: installBootLoader() takes exactly 1 argument (2 given)
[root@i5000e root]#

Expected Results:  I expected successful installation of the kernel, as I have
always seen in the past.

Additional info:

The same traceback also happens when I use a Current (RHN protocol) server
instead of arjanv's yum repository.
Comment 1 Bill Nottingham 2003-08-22 11:49:21 EDT

*** This bug has been marked as a duplicate of 102804 ***
Comment 2 Barry K. Nathan 2003-08-26 17:40:46 EDT
I can confirm that this bug is fixed in up2date 3.9.12.
Comment 3 Red Hat Bugzilla 2006-02-21 13:58:11 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.