Bug 1028765 - [RFE] Display canDoAction messages from commands executed during the flow after the initial canDoAction checks succeeded
[RFE] Display canDoAction messages from commands executed during the flow aft...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Ravi Nori
Pavel Stehlik
infra
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-10 10:07 EST by Elad
Modified: 2016-02-10 14:06 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 06:35:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
engine.log and screenshot (4.87 MB, application/x-gzip)
2013-11-10 10:07 EST, Elad
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 24066 None None None Never

  None (edit)
Description Elad 2013-11-10 10:07:11 EST
Created attachment 822090 [details]
engine.log and screenshot

Description of problem:
When live storage migration fails because another operation was managed to take a lock on the disk, user don't get any error about the failure.
Happened to me when during LSM, I tried to attach the disk snapshot to another VM with REST (as part of the new backup-API feature) 

Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.32.beta1.el6ev.noarch
rhevm-webadmin-portal-3.3.0-0.32.beta1.el6ev.noarch


How reproducible:
100%

Steps to Reproduce:
On a block/file pool with 2 SDs:
1. create 2 VMs with disk and run them 
2. live migrate one of the VMs disk to the second SD
3. during the LSM operation (right after it began), attach the disk snapshot (the one that is simultaneously  migrating) to the other running vm using REST

Actual results:
The disk attachment operation succeeds and LSM fails.

LSM is failing with a CanDoAction:

2013-11-10 15:56:12,613 WARN  [org.ovirt.engine.core.bll.lsm.LiveMigrateVmDisksCommand] (ajp-/127.0.0.1:8702-4) [47722e08] CanDoAction of action LiveMigrateVmDisks failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_D
ISK,ACTION_TYPE_FAILED_VM_DISK_SNAPSHOT_IS_PLUGGED_TO_ANOTHER_VM,$disksInfo

User don't get any notification about the LSM failure 

Expected results:
Engine should report about the failure on UI.

Additional info: engine.log and screenshot
Comment 1 Liron Aravot 2013-11-25 11:43:45 EST
The main issue is that after the command execution has started, CDA messages from called commands during the execution flow (including LSM) won't be displayed as the command is already being executed.

The issue specifically in that bug was resolved by the given patch as the taken locks were removed from LiveMigrateDiskCommand (for other CDA messages there will be an audit log).

Therefore i'm changing this to a RFE of displaying CDA messages from commands executed after initial CDA checks were done.
Comment 3 Itamar Heim 2014-01-23 12:58:38 EST
is this done or not? the only associated patch to this bug is merged?
Comment 4 Liron Aravot 2014-01-27 04:47:44 EST
Not done, the provided patch solves the bug - but doesn't implplement the RFE related to it.
Comment 9 Moti Asayag 2015-11-12 06:35:51 EST
Bug is closed due to a missing use case. Also I'd avoid auto-logging messages to the audit log which has no audit-log-type since this bypass the audit-log messages flooding mechanism.

Note You need to log in before you can comment on or make changes to this bug.