Bug 102877 - porky.devel.redhat.com coded into cgi-bin files
porky.devel.redhat.com coded into cgi-bin files
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-22 02:28 EDT by bill parducci
Modified: 2007-04-18 12:57 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-22 10:16:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2003-08-22 02:28:50 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.2) Gecko/20030208
Netscape/7.02

Description of problem:
i just installed mailman-2.1-8 and it appears that this:

http://porky.devel.redhat.com/pipermail/jambalaya/

is *coded* into the cgi-bin file for the 'Go To List Archives' link!?

i created two different lists with the same results. ALL other links work properly.

Version-Release number of selected component (if applicable):
mailman-2.1-8

How reproducible:
Always

Steps to Reproduce:
1.clean install of this version of mailman
2. create a list
3. check link for 'Go To List Archives'
    

Actual Results:  link is:

http://www.pier64.com/mailman/admindb/[list]

Expected Results:  link should be:

http://[domain]/mailman/admindb/[list]

Additional info:

i cannot use this version of the code with this problem and because it is
compiled, i cannot change the HTML behind it as a work around without
recompiling the code
Comment 1 John Dennis 2003-08-22 10:16:44 EDT
Actually I don't think its hardcoded into any compiled files but instead due a
bug in the rpm it ended up in one of the mailman configure files. I think you
have two choices. You can either upgrade to the current rpm, which is what I
suggest, or you can edit the config file. There are two files to look at, both
in /var/mailman/Mailman and the two files are Defaults.py and mm_cfg.py.

To get the latest-pkg which is 2.1.2-2 goto ftp.redhat.com and cd to:

/pub/redhat/linux/rawhide/i386/RedHat/RPMS

Note You need to log in before you can comment on or make changes to this bug.