Bug 1028861 - [WHQL][vioscsi]Embedded Signature Verification failed on win2k8-32/64 guest on DTM as it is not a signed driver
[WHQL][vioscsi]Embedded Signature Verification failed on win2k8-32/64 guest o...
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.0
Unspecified Unspecified
high Severity high
: rc
: 7.0
Assigned To: Vadim Rozenfeld
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 00:12 EST by Min Deng
Modified: 2015-01-16 04:04 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-25 11:36:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
signtool results (3.36 KB, text/plain)
2013-11-25 04:01 EST, Min Deng
no flags Details
screenshot from windows server 2008 (40.07 KB, image/png)
2013-12-12 22:28 EST, Mike Cao
no flags Details

  None (edit)
Description Min Deng 2013-11-11 00:12:15 EST
Description of problem:
Running Embedded Signature Verification job on win2k8-32/64 guests but they all failed

Version-Release number of selected component (if applicable):
virtio-win-prewhql-0.1-73
qemu-kvm-rhev-0.12.1.2-2.405.el6.x86_64
kernel-2.6.32-420.el6.x86_64

How reproducible:
4 times

Steps to Reproduce:
1./usr/libexec/qemu-kvm -M rhel6.5.0 -m 6G -smp 4,cores=4 -cpu cpu64-rhel6,+x2apic -usb -device usb-tablet -netdev tap,sndbuf=0,id=hostnet0,script=/etc/qemu-ifup,downscript=no -device e1000,netdev=hostnet0,mac=00:12:37:41:52:41 -uuid 3c14ce6c-4715-42b0-8e73-2e4000d7730f -no-kvm-pit-reinjection -chardev socket,id=111a,path=/tmp/monitor-win2k8-32-scsi,server,nowait -mon chardev=111a,mode=readline -name win2k8-64-scsi -vnc :1 -vga cirrus -rtc base=localtime,clock=host,driftfix=slew -chardev socket,id=seabios_debug,path=/tmp/monitor-seabios,server,nowait -device isa-debugcon,iobase=0x402,chardev=seabios_debug -drive file=win2k8-64-scsi.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk0 -drive file=disk1.raw,if=none,media=disk,format=raw,rerror=stop,werror=stop,cache=none,aio=native,id=scsi-disk1,serial=aaa -device virtio-scsi-pci,id=bus1 -device scsi-hd,bus=bus1.0,drive=scsi-disk0,id=disk,serial=test,bootindex=1 -device virtio-scsi-pci,id=bus2 -device scsi-hd,bus=bus2.0,drive=scsi-disk1,id=disk1,serial=test1 -global PIIX4_PM.disable_s3=1 -global PIIX4_PM.disable_s4=0 -monitor stdio
2.submit the job to DTM
3.

Actual results:
The job failed 
Expected results:
The job can pass.

Additional info:
Upload cpk file to the bug
Comment 1 Min Deng 2013-11-11 00:17:35 EST
Created attachment 822272 [details]
CPK
Comment 3 Min Deng 2013-11-11 03:11:32 EST
Hi all,
   I've tried the bug on HCK but it still failed with the same error.
Thanks
Min
Comment 4 Vadim Rozenfeld 2013-11-11 03:30:48 EST
(In reply to dengmin from comment #3)
> Hi all,
>    I've tried the bug on HCK but it still failed with the same error.
> Thanks
> Min

Do you see the same problem on Win8/WS2012 ?

Thanks,
Vadim
Comment 5 Min Deng 2013-11-11 03:53:48 EST
(In reply to Vadim Rozenfeld from comment #4)
> (In reply to dengmin from comment #3)
> > Hi all,
> >    I've tried the bug on HCK but it still failed with the same error.
> > Thanks
> > Min
> 
> Do you see the same problem on Win8/WS2012 ?
> 
> Thanks,
> Vadim

Hi Vadim,
   The issue doesn't happen on win8 and win2012 guest,and there was a fixed bug about this job - https://bugzilla.redhat.com/show_bug.cgi?id=690713,they are very similar so it maybe helpful,any issues please let me know.
   
Thanks 
Min
Comment 6 Mike Cao 2013-11-11 03:59:43 EST
I check the all the testing results find that win7-32/64,win2k8R2 does not hit this issue on HCK2.0 while their drivers are same as the win2k8's which are running on WLK1.6
Comment 7 Min Deng 2013-11-20 05:17:39 EST
Unfortunately,the job still failed via build 74,so please double check,thanks
Comment 8 Vadim Rozenfeld 2013-11-20 05:34:07 EST
(In reply to dengmin from comment #7)
> Unfortunately,the job still failed via build 74,so please double check,thanks

Thanks,
looks like some problems in the build VM itself.
Will thry to find out what's wrong with it asap.

Vadim.
Comment 9 Vadim Rozenfeld 2013-11-25 03:35:19 EST
could you please verify the vioscsi signature manually with signtool, like 
"signtool verify /pa /v vioscsi.sys" and post the output?

Thanks,
Vadim.
Comment 10 Min Deng 2013-11-25 04:00:48 EST
Hi Vadim,

   The vioscsi driver for win2k8 guest has been verified successful.And please see the detail attachments.

Thanks
Min
Comment 11 Min Deng 2013-11-25 04:01:40 EST
Created attachment 828570 [details]
signtool results
Comment 12 Vadim Rozenfeld 2013-11-25 04:36:30 EST
Thanks, Min.

It's what I'm getting on my system as well.

Best regards,
Vadim.
Comment 13 Mike Cao 2013-11-25 04:44:00 EST
(In reply to Vadim Rozenfeld from comment #12)
> Thanks, Min.
> 
> It's what I'm getting on my system as well.
> 
> Best regards,
> Vadim.

FYI .
We may hit http://osronline.com/showThread.CFM?link=230046
Comment 19 Min Deng 2013-11-29 01:53:30 EST
  Double check,the job passed on hck2.0 on both win2k8-64 and win2k8-32 guest (build74)
  Thanks
  Min
Comment 20 Yan Vugenfirer 2013-12-08 08:32:25 EST
Please provide 32bit CPK as well.

Thanks,
Yan.
Comment 22 Min Deng 2013-12-11 02:43:08 EST
Hi Yan,

   Upload cpk&hck to the bug,any issues please let me know.
Thanks
Min
Comment 23 Min Deng 2013-12-11 02:49:03 EST
Created attachment 835154 [details]
LOG
Comment 24 Yan Vugenfirer 2013-12-11 04:12:35 EST
Thanks!
Comment 25 Mike Cao 2013-12-12 22:26:35 EST
(In reply to Vadim Rozenfeld from comment #12)
> Thanks, Min.
> 
> It's what I'm getting on my system as well.
> 
> Best regards,
> Vadim.

Vadim .mdeng 

Which platform are you using to run signtool for windows server 2008 ?
It failed on the windows 2008 .
Referring to the screen dump
Comment 26 Mike Cao 2013-12-12 22:28:11 EST
Created attachment 836111 [details]
screenshot from windows server 2008
Comment 27 Min Deng 2013-12-12 22:55:09 EST
Created attachment 836116 [details]
from win2008 guest
Comment 28 Vadim Rozenfeld 2013-12-12 23:18:42 EST
I tested on WS2012
Comment 29 Mike Cao 2013-12-13 00:20:47 EST
(In reply to Vadim Rozenfeld from comment #28)
> I tested on WS2012

Vadim .So that should be the key point .
We need to run signtool for the specified operation system (2008) to see whether the driver is digital signed in such os .
Comment 30 Vadim Rozenfeld 2013-12-13 04:45:49 EST
(In reply to Mike Cao from comment #29)
> (In reply to Vadim Rozenfeld from comment #28)
> > I tested on WS2012
> 
> Vadim .So that should be the key point .
> We need to run signtool for the specified operation system (2008) to see
> whether the driver is digital signed in such os .

I will recheck it on W2K8

Cheers,
Vadim
Comment 35 Ronen Hod 2014-03-25 07:00:19 EDT
Mike Cao,
Where do we stand with this bug?
Deferring, since anyhow an Internet connection solves it.
Comment 36 Mike Cao 2014-03-25 11:36:26 EDT
dengmin,,pls mark it in our FAQ

Note You need to log in before you can comment on or make changes to this bug.