Bug 1028918 - business central guided editors don't see objects not created by data modeler
business central guided editors don't see objects not created by data modeler
Status: CLOSED DUPLICATE of bug 1001561
Product: JBoss BRMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: manstis
Lukáš Petrovický
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 03:39 EST by Anthony Patricio
Modified: 2013-11-11 03:44 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 03:44:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anthony Patricio 2013-11-11 03:39:15 EST
Description of problem:
If you implement your objects outside business central but inside the project (using git and IDE typically), the guided editors won't be able to import these objects, follow steps to reproduce the issue.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. create a new project (ie: com.example.testproject)
2. clone it in eclipse or whatever
3. create a new package (important!), for example the default package followed by .factmodel (com.example.testproject.factmodel)
4. create a java class
5- commit push
6- refresh business central, the package and class is here -> no problem so far
7- select the default package (not com.example.testproject) and create a rule or guided decision table -> impossible to catch the class

Workaround: create another object in com.example.testproject.factmodel using the data modeler.

Actual results:


Expected results:


Additional info:
Comment 2 Lukáš Petrovický 2013-11-11 03:44:17 EST
This is a duplicate of a known issue that is currently scheduled to be fixed in the next build.

*** This bug has been marked as a duplicate of bug 1001561 ***

Note You need to log in before you can comment on or make changes to this bug.