Bug 1028922 - [engine-backend] [external-provider] [glance] [RFE] add the option to run VM directly from glance image
[engine-backend] [external-provider] [glance] [RFE] add the option to run VM ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.3.0
x86_64 Unspecified
unspecified Severity high
: ---
: 3.3.0
Assigned To: Andrew Cathrow
Shai Revivo
storage
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 03:44 EST by Elad
Modified: 2016-02-10 15:27 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 04:23:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Elad 2013-11-11 03:44:27 EST
As part of glance integration with RHEV, we are able to add glance images to existing VMs in RHEV as disks, after we import those images from glance.

Glance should have the ability to run RHEV VMs directly from its image repository, without importing the images to RHEV.
Comment 1 Ayal Baron 2013-11-11 04:23:41 EST
(In reply to Elad from comment #0)
> As part of glance integration with RHEV, we are able to add glance images to
> existing VMs in RHEV as disks, after we import those images from glance.
> 
> Glance should have the ability to run RHEV VMs directly from its image
> repository, without importing the images to RHEV.

If you'd like to add functionality to glance then please open an rfe on glance.

What glance supports is:
1. retrieving an image over http - does not support random access, so cannot run VMs this way
2. multi-locations for image - in this way, in the special case where a host is able to reach the image not only through glance but also through direct access to its backend then you can use it directly.  However, the correct way to do this is have Cinder as the backend for glance and then choose the cinder volume to back your disks.

Glance is an external service and there is no guarantee that it will remain available in which case, disks created from it might be rendered useless.  In openstack this is fine since the disks created from it are considered ephemeral anyway.  In oVirt, however, this is not the case.
Comment 2 Elad 2013-11-14 03:11:02 EST
(In reply to Ayal Baron from comment #1)
This ability is existing on glance. as far as I know, open-stack has the ability to create VMs directly from glance images. Can't we replicate this ability to RHEV?
Comment 3 Elad 2013-11-14 06:27:49 EST
Sorry Ayal, you have already answered to my question in your comment. I'm removing the need info.

Note You need to log in before you can comment on or make changes to this bug.