Bug 1028950 - The "Welcome" info is shown on partner potal with wrong element
The "Welcome" info is shown on partner potal with wrong element
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Website (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jessica Forrester
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 05:23 EST by Tian Feng
Modified: 2015-05-14 21:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-23 22:29:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Welcome (3.26 KB, image/png)
2013-11-11 05:23 EST, Tian Feng
no flags Details
Welcome Ready Partner (5.18 KB, image/png)
2013-11-11 05:24 EST, Tian Feng
no flags Details
Welcome Advanced Partner (5.19 KB, image/png)
2013-11-11 05:24 EST, Tian Feng
no flags Details

  None (edit)
Description Tian Feng 2013-11-11 05:23:17 EST
Description of problem:
Go to partner potal and check "Welcome" info. It is with icon showing warning triangle. Check its source code and find class="alert alert-error" causes this situation.
Since website has new theme(CSS), so this info should be updated to avoid misleading users.See detail in attachment.

Version-Release number of selected component (if applicable):
devenv_4016

How reproducible:
Always

Steps to Reproduce:
1. Go to partner/portal and check "Welcome" info
2. Apply for a partner and then being permitted to be a partner. Go to parner/portal and check "Welcome Ready Partner".
3. Set this user as advanced partner. then check "Welcome Advanced Partner" info.

Actual results:
The "Welcome" info is with icon showing warning triangle.

Expected results:
The "Welcome" info should be proper to avoid misleading users.

Additional info:
Comment 1 Tian Feng 2013-11-11 05:23:48 EST
Created attachment 822341 [details]
Welcome
Comment 2 Tian Feng 2013-11-11 05:24:13 EST
Created attachment 822342 [details]
Welcome Ready Partner
Comment 3 Tian Feng 2013-11-11 05:24:51 EST
Created attachment 822343 [details]
Welcome Advanced Partner
Comment 4 Jessica Forrester 2013-11-11 10:08:04 EST
Fix is in https://github.com/openshift/li/pull/2128
Comment 5 openshift-github-bot 2013-11-11 11:25:43 EST
Commit pushed to master at https://github.com/openshift/li

https://github.com/openshift/li/commit/f78eff68cdae9384e7368f00837362b3d622fd1b
Bug 1028950 - partner portal welcome shouldnt have warning icon
Comment 6 Tian Feng 2013-11-11 21:46:13 EST
Test on devenv_4018, all "welcome" info can be shown properly. So verify this bug, thanks!

Note You need to log in before you can comment on or make changes to this bug.