Bug 102900 - libcom_err.so.3 shared object has disappeared since 1.2.8
libcom_err.so.3 shared object has disappeared since 1.2.8
Product: Red Hat Raw Hide
Classification: Retired
Component: krb5 (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Depends On:
  Show dependency treegraph
Reported: 2003-08-22 10:31 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2003-08-22 11:21:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-08-22 10:31:12 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030722 Galeon/1.3.7

Description of problem:
I'm trying to isolate a problem with the Rawhide cyrus-sasl package (which
requires krb5-devel).  krb5-1.3.1-1, in turn, requires e2fsprogs to be at least
1.33 level.  Upon recompiling the krb5 package set, I attempted to upgrade to
the new packages and get the following:

... <build process snip> ...
Wrote: /usr/src/redhat/RPMS/i686/krb5-devel-1.3.1-1.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/krb5-libs-1.3.1-1.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/krb5-server-1.3.1-1.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/krb5-workstation-1.3.1-1.i686.rpm
Wrote: /usr/src/redhat/RPMS/i686/krb5-debuginfo-1.3.1-1.i686.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.45867
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd krb5-1.3.1
+ '[' /var/tmp/krb5-root '!=' / ']'
+ rm -rf /var/tmp/krb5-root
+ exit 0
# rpm -Uvh ../RPMS/i686/krb5-*

error: Failed dependencies:
	libcom_err.so.3 is needed by (installed) pine-4.44-18
	libcom_err.so.3 is needed by (installed) cyrus-sasl-2.1.10-4
	libcom_err.so.3 is needed by (installed) cyrus-sasl-devel-2.1.10-4
	libcom_err.so.3 is needed by (installed) cyrus-sasl-gssapi-2.1.10-4
	libcom_err.so.3 is needed by (installed) elinks-0.4.2-1
	libcom_err.so.3 is needed by (installed) wget-1.8.2-9
	libcom_err.so.3 is needed by (installed) cvs-1.11.5-1
	libcom_err.so.3 is needed by (installed) curl-7.10.4-1
	libcom_err.so.3 is needed by (installed) openssh-3.6.1p2-1
	libcom_err.so.3 is needed by (installed) openssh-clients-3.6.1p2-1
	libcom_err.so.3 is needed by (installed) openssh-server-3.6.1p2-1
	libcom_err.so.3 is needed by (installed) php-4.3.2-6
	libcom_err.so.3 is needed by (installed) php-imap-4.3.2-6
	libcom_err.so.3 is needed by (installed) postgresql-server-7.3.3-4
	libcom_err.so.3 is needed by (installed) samba-common-3.0.0-3beta3
	libcom_err.so.3 is needed by (installed) samba-3.0.0-3beta3
	libcom_err.so.3 is needed by (installed) samba-client-3.0.0-3beta3
	libcom_err.so.3 is needed by (installed) samba-swat-3.0.0-3beta3
	libcom_err.so.3 is needed by (installed) imap-2002d-2
	libcom_err.so.3 is needed by (installed) httpd-2.0.47-4
	libcom_err.so.3 is needed by (installed) openssl-0.9.7a-16
	libcom_err.so.3 is needed by (installed) gnome-vfs2-2.3.7-1
	libcom_err.so.3 is needed by (installed) pam_krb5-2.0.1-1

# locate libcom_err

Upon inspecting who provides (with RHL9) libcom_err.so.3:

# rpm -qf /usr/kerberos/lib/libcom_err.so.3

So what happened to the shared object?  krb5.spec specifies:

* Wed Jun 18 2003 Nalin Dahyabhai <nalin@redhat.com> 1.3-0.beta.4
- test update to 1.3 beta 4
- ditch statglue build option  
- krb5-devel requires e2fsprogs-devel, which now provides libss and libcom_err

This bug may need to have its component switched (since the shared object in
question has been moved).  I had already upgraded e2fsprogs/e2fsprogs-devel to
Rawhide 1.34-1.

Upon viewing e2fsprogs, I've found:

cd ${RPM_BUILD_ROOT}%{_libdir}
ln -sf %{_root_libdir}/libcom_err.so.2 libcom_err.so

e2fsprogs *does* provide an older version of the shared object.  

# find ../BUILD/krb5-1.3.1/ -type f | grep libcom_err

The above returns zero results.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. see description


Actual Results:  Upgrade of krb5 packages fails because of a missing shared object.

Expected Results:  Upgrade goes as plans.

Additional info:
Comment 1 Michael Lee Yohe 2003-08-22 10:32:37 EDT
Adding a few Red Hat developers (in case this is really an e2fsprogs component
Comment 2 Bill Nottingham 2003-08-22 11:21:21 EDT
Correct, you need to upgrade the affected packages that require libcom_err as well.
Comment 3 Vladimir Kondratiev 2004-05-19 04:59:31 EDT
Current Mozilla test release, 1.7rc2, require libcomm_err.so.3

When installing, the following error reported:
nsNativeComponentLoader: SelfRegisterDll(libnegotiateauth.so) Load
FAILED with error: libcom_err.so.3: cannot open shared object file: No
such file or directory

I have no permission to reopen this bug, could someone more powerful
take care of it?
Comment 4 Nalin Dahyabhai 2004-05-19 11:10:20 EDT
The negotiate plugin needs to be rebuilt with the versions of the
libraries which you have.

Note You need to log in before you can comment on or make changes to this bug.