Bug 1029026 - [REPORTS] - When creating reports, APPLY button doesn't close the setup screen
[REPORTS] - When creating reports, APPLY button doesn't close the setup screen
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: jasperreports-server-pro (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Yaniv Lavi
Barak Dagan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 09:01 EST by Barak Dagan
Modified: 2014-07-13 19:20 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 11:02:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Barak Dagan 2013-11-11 09:01:55 EST
Description of problem:
The Apply button, in the setup (input controls) screen, doesn't close that screen, although the report is being generated beneath.

Version-Release number of selected component (if applicable):
IS19 - IS22

How reproducible:
100%

Steps to Reproduce:
1. create reports, either from web admin or reports admin
2. select the desired parameters / data
3. press the apply button

Actual results:


Expected results:


Additional info:
Comment 1 Yaniv Lavi 2013-11-11 11:02:00 EST
Apply keeps the input controls open. ok closes and run the reports.
It's like that by design.


Yaniv
Comment 2 Barak Dagan 2013-11-12 02:35:50 EST
(In reply to Yaniv Dary from comment #1)
> Apply keeps the input controls open. ok closes and run the reports.
> It's like that by design.
> 
> 
> Yaniv

As I mentioned before - Apply keeps the controls open AND runs the reports
Comment 3 Yaniv Lavi 2013-11-12 05:50:20 EST
(In reply to Barak Dagan from comment #2)
> (In reply to Yaniv Dary from comment #1)
> > Apply keeps the input controls open. ok closes and run the reports.
> > It's like that by design.
> > 
> > 
> > Yaniv
> 
> As I mentioned before - Apply keeps the controls open AND runs the reports

and as i said this is the exact purpose of this button.


Yaniv

Note You need to log in before you can comment on or make changes to this bug.