Bug 1029033 - Link status shows disconnected although the cable is plugged.
Link status shows disconnected although the cable is plugged.
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: ovirt-node (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: 3.5.0
Assigned To: Fabian Deutsch
bugs@ovirt.org
node
:
Depends On:
Blocks: 1029263
  Show dependency treegraph
 
Reported: 2013-11-11 09:15 EST by haiyang,dong
Modified: 2016-02-10 14:40 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029263 (view as bug list)
Environment:
Last Closed: 2014-10-17 08:25:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 21130 None None None Never

  None (edit)
Description haiyang,dong 2013-11-11 09:15:30 EST
Description of problem:
The link status of network details page detect the physical connected state of a network cable/connector.
but after clean install ovirt-node-iso-3.1.0-0.999.1209.el6.iso and select one nic into network details page, check that
Link status shows disconnected although the cable is plugged.


Version-Release number of selected component (if applicable):
ovirt-node-iso-3.1.0-0.999.1209.el6.iso

How reproducible:
100%

Steps to Reproduce:

Actual results:


Expected results:
Link status shows connected when the cable is plugged.

Additional info:
Comment 1 Fabian Deutsch 2013-11-11 10:42:58 EST
Hey,

do you know what the root cause is? The ip cmd lacking functionality or driver problems, ...?
Comment 2 haiyang,dong 2013-11-11 21:36:28 EST
(In reply to Fabian Deutsch from comment #1)
> Hey,
> 
> do you know what the root cause is? The ip cmd lacking functionality or
> driver problems, ...?

This is due to it miss to execute "ip link set dev {dev} up" before check "1" in
/sys/class/net/{dev}/carrier.
Comment 3 Sandro Bonazzola 2014-03-04 04:22:28 EST
This is an automated message.
Re-targeting all non-blocker bugs still open on 3.4.0 to 3.4.1.
Comment 4 Sandro Bonazzola 2014-05-08 09:56:30 EDT
This is an automated message.

oVirt 3.4.1 has been released.
This issue has been retargeted to 3.5.0 since it has not been marked as high priority or severity issue, please retarget if needed.
Comment 5 Sandro Bonazzola 2014-10-17 08:25:22 EDT
oVirt 3.5 has been released and should include the fix for this issue.

Note You need to log in before you can comment on or make changes to this bug.