Bug 102909 - using startx for a 2nd user, no cursor on display 1 terminal
Summary: using startx for a 2nd user, no cursor on display 1 terminal
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-terminal
Version: 9
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-08-22 15:28 UTC by Glenn Simpson
Modified: 2007-04-18 16:57 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2004-04-14 03:51:30 UTC


Attachments (Terms of Use)

Description Glenn Simpson 2003-08-22 15:28:45 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

Description of problem:
Log in as a 2nd user, using Gnome on display 1.
The screen at CTL-ALT-F8 is activated.
Open a text terminal (start -> System Tools -> terminal
The window opens but without a text cursor.
It is impossible to do anything within the dialog window suggesting
the focus has not been set to the this window.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Arbitrarily log in as root to the Gnome GUI
2.switch to a text terminal ( CTL-ALT-F2 )
3.log in as a normal user (ex: joe with password)
4.when logged in, issue "startx -- :1" to put this user in GUI mode
  on display screen at CNT-ALT-F8
5.Open a text terminal on the GUI display
  (start -> System Tools -> Terminal)
6.Note the text terminal opens. But the dialog box does not have a
  cursor. You can not make any use of the text terminal(s) on
  the display at CNT-ALT-F8
    

Actual Results:  For the above condition, you can not get a cursor, or make any
entry
on the text terminal dialog box at CNT-ALT-F8

Expected Results:  When the terminal is opened, the cursor position should allow
normal keyboard actions.

Additional info:

I have used this mode on RH 7.0 through RH 8, and the mode has always been
available to my Gnome operations.

Comment 1 Havoc Pennington 2003-10-04 05:39:28 UTC
Presumably an X bug... or maybe you don't have a window manager in your startx,
or something?


Comment 2 Mike A. Harris 2003-10-06 15:09:54 UTC
I'm not quite sure I understand how exactly this is considered an XFree86 bug.
;o)

Sounds to me much more like a bug in the terminal application you are using.
You haven't mentioned which terminal you're using, but presumeably that icon
starts up gnome-terminal.

Reassigning to gnome-terminal component for analysis.

Comment 3 Glenn Simpson 2003-10-29 20:22:29 UTC
This bug disappeared when I rebuilt the system.  The original cause is unknown.
I could use startx -- :1 but the problem WAS persistent.

I recommend you close this bug as it no longer can be reproduced.


Note You need to log in before you can comment on or make changes to this bug.