Bug 1029103 - Xfce spin installer partitioner goes in circles
Xfce spin installer partitioner goes in circles
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 11:45 EST by lothar_
Modified: 2013-11-11 11:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-11 11:50:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lothar_ 2013-11-11 11:45:29 EST
Xfce spin installer partitioner goes in circles

attempting to install Fedora 19 from the Xfce spin,
the partitioner does not permit to deploy a user-given partition scheme. 

the machine is a notebook with amd64 processor and uefi bios and secure boot capability: 

  HP 2000-bf69WM AMD Dual-Core Processor E-300(1.3GHz) 15.6" 4GB Memory 320GB HDD AMD Radeon HD 6310 Notebook

the live dvd image was taken from:
  http://download.fedoraproject.org/pub/alt/releases/19/Spins/x86_64/Fedora-Live-XFCE-x86_64-19-1.iso

the live dvd was booted in efi mode with secure boot enabled.

the hard drive had partitions of the desired type and size and order.


here is the initial sequence of events:
from window: [[ installation summary]] choose item: storage

goes to window: [[ installation destination ]]
this shows something like:
  select the device(s) you'd like to install to. ...

  local standard disks

  305.24 gb
  atast320lt020-9yg14
  sda / 1.3 mb free

  one disk selected 305.24 gb capacity, 1.30 mb free

  link: full disk summary and bootloader ...  # link


click link: "full disk summary and bootloader ..."

pops up small window: [[ selected disks ]] # small window

  boot description                   name capacity  free
  x    ata st320lt020-9yg14 w048j2yl sda  305.24 gb 1.30 mb 
 
  ((set as boot device)) ((remove))   # buttons

  1 disk 305.24 gb capacity, 1.30 mb free (unpartitioned and in filesystems)
  ((close))   # button

press button: ((close)) # button

goes to window: [[ installation destination ]]
press button: ((done))

pops up small window: [[ installation options ]] # small window
  your current fedora software selection requires 5.55 gb of available space ...

  you don't have enough space available to install fedora. ...

  partition scheme: standard partition 
  ((cancel and add more disks)) ((custom partitioning)) ((reclaim space)) 
press button: ((custom partitioning)) 

goes to window: [[ manual partitioning ]]

display in left small window: [[ ]]
  - new fedora 19 installation 
    you haven't selected any mountpoints for your fedora 19 installation yet.
    you can 
    - click here to create them automatically
    - create new mount points by clicking the '+' button

  - unknown
    sda1  ntfs      400 mb
    sda10 swap      6.96 gb
    sda11 ntfs      21.01 gb
    sda2  efi system partition      260 mb
    sda3  unknown   128 mb
    sda4  ntfs      77.12 gb
    sda5  ntfs      77.12 gb
    sda6  ntfs      77.12 gb
    sda7  ext4      30.50 gb
    sda8  ext4      7.16 gb
    sda9  ext4      7.16 gb

in right small window: [[ ]]
successively specified mountpoints and formatting as follows,
  sda7 - ext4, /home, format
  sda8 - ext4, /, format
  sda9 - ext4, /data, format
  sda10 - swap, n/a, format

this gave a final structure of:

display in left small window: [[ ]]
- new fedora 19 installation 

  sda7 ext4     30.50 gb
  sda8 ext4      7.16 gb
  sda9 ext4      7.16 gb
  sda10 swap     6.96 gb

- unknown
  sda1  ntfs      400 mb
  sda11 ntfs      21.01 gb
  sda2  efi system partition      260 mb
  sda3  unknown   128 mb
  sda4  ntfs      77.12 gb
  sda5  ntfs      77.12 gb
  sda6  ntfs      77.12 gb

press button: ((done)) 
brings up window: [[ summary of changes ]] 
  your customizations will result in the following changes taking effect on the disks you've selected
  destroy format - ext4 sda8 
  destroy format - ext4 sda9
  destroy format - swap sda10 
  destroy format - ext4 sda7 
  create format - ext4 sda8  /
  create format - ext4 sda9  /data
  create format - swap sda10 
  create format - ext4 sda7 /home 
  ((cancel and return to custom partitioning)) ((accept changes)) 
press button: ((accept changes)) 

goes to window: [[ installation summary]]
    ...
  - storage
    installation destination
    custom partitioning selected 
  # here storage choice has yellow bang triangle - error checking storage configuration

# bottom yellow bar - please complete items marked with the icon before continuing to the next step

choose item: storage
goes to window: [[ installation destination ]]
# bottom yellow bar - error checking storage configuration. click for details
click - bottom yellow bar  

pops up small window: [[ ]]
  the following errors were encountered when checking your storage configuration. you can modify your storage layout or quit the installer.

  you have not created a bootloader stage1 target device

press button: ((modify storage layout)) 
goes to window: [[ manual partitioning ]]

at this point we are starting on a fresh partition allocation and are repeating what was already done. 

how to convince the installer that there is a stage1 target device?

note that in the above scheme the efi partition is still classified under unknown
and not as part of new fedora 19 installation, but the efi partition must be part of the new system. 

however, it does not work to give a mountpoint to /dev/sda2 -  efi system partition and it certainly should not be formatted.

always after setting up the partition layout in window: [[ manual partitioning ]], 
on returning to window: [[ installation summary]] 

there is still the notice: 
  bottom yellow bar - error checking storage configuration. click for details.

which clicking pops up small window: [[ ]]
  the following errors were encountered when checking your storage configuration. you can modify your storage layout or quit the installer.

  you have not created a bootloader stage1 target device

there seems to be no way to make the installation work with my manual formatting scheme.
Comment 1 David Shea 2013-11-11 11:50:22 EST
You need a EFI System Partition mounted at /boot/efi

Note You need to log in before you can comment on or make changes to this bug.