This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1029118 - Can not be installed to a missing dependency on EL6
Can not be installed to a missing dependency on EL6
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
3.3
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Douglas Schilling Landgraf
Haim
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 12:13 EST by Fabian Deutsch
Modified: 2013-11-28 07:19 EST (History)
13 users (show)

See Also:
Fixed In Version: vdsm-4.13.0-11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-28 07:19:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fabian Deutsch 2013-11-11 12:13:47 EST
Description of problem:
edit-node fails with 
Error: Package: vdsm-4.13.0-9.el6.x86_64 (ovirt-beta)
           Requires: hostname

This is blocking a ovirt-node-iso respin.

Version-Release number of selected component (if applicable):
latest beta 
--> Running transaction check
---> Package ovirt-node-plugin-vdsm.noarch 0:0.1.1-4.el6 will be installed

How reproducible:
always

Steps to Reproduce:
On CenOS6:

# ./ovirt-node/tools/edit-node --repo edit-node-el6.repo --install ovirt-node-plugin-vdsm ovirt-node-iso-3.0.2-1.0.0.el6.iso 
ovirt-node-iso-3.0.2-1.0.0.el6.iso
Setting SELinux Permissive During Yum Install
Installing Packages
Setting Up DNS For Chroot
Configuring Yum Repo
Running Yum Install
Failed to set locale, defaulting to C
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package ovirt-node-plugin-vdsm.noarch 0:0.1.1-4.el6 will be installed
--> Processing Dependency: vdsm-reg >= 4.10.3 for package: ovirt-node-plugin-vdsm-0.1.1-4.el6.noarch
--> Processing Dependency: ovirt-host-deploy-offline >= 1.1.0 for package: ovirt-node-plugin-vdsm-0.1.1-4.el6.noarch
--> Processing Dependency: vdsm-gluster for package: ovirt-node-plugin-vdsm-0.1.1-4.el6.noarch
--> Running transaction check
---> Package ovirt-host-deploy-offline.noarch 0:1.1.1-1.el6 will be installed
--> Processing Dependency: vdsm-cli for package: ovirt-host-deploy-offline-1.1.1-1.el6.noarch
--> Processing Dependency: vdsm for package: ovirt-host-deploy-offline-1.1.1-1.el6.noarch
--> Processing Dependency: m2crypto for package: ovirt-host-deploy-offline-1.1.1-1.el6.noarch
---> Package vdsm-gluster.noarch 0:4.13.0-9.el6 will be installed
--> Processing Dependency: python-magic for package: vdsm-gluster-4.13.0-9.el6.noarch
--> Processing Dependency: glusterfs-server for package: vdsm-gluster-4.13.0-9.el6.noarch
---> Package vdsm-reg.noarch 0:4.13.0-9.el6 will be installed
--> Running transaction check
---> Package glusterfs-server.x86_64 0:3.4.0-8.el6 will be installed
--> Processing Dependency: glusterfs-cli = 3.4.0-8.el6 for package: glusterfs-server-3.4.0-8.el6.x86_64
---> Package m2crypto.x86_64 0:0.20.2-9.el6 will be installed
---> Package python-magic.x86_64 0:5.04-15.el6 will be installed
---> Package vdsm.x86_64 0:4.13.0-9.el6 will be installed
--> Processing Dependency: vdsm-xmlrpc = 4.13.0-9.el6 for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: vdsm-python = 4.13.0-9.el6 for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: sanlock >= 2.3-4 for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-ethtool >= 0.6-3 for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: mom >= 0.3.2-3 for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: tree for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: sanlock-python for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-pthreading for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-netaddr for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-inotify for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-dmidecode for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: python-argparse for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: pyparted for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: libvirt-lock-sanlock for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: hostname for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: glusterfs-api for package: vdsm-4.13.0-9.el6.x86_64
--> Processing Dependency: fence-agents for package: vdsm-4.13.0-9.el6.x86_64
---> Package vdsm-cli.noarch 0:4.13.0-9.el6 will be installed
--> Processing Dependency: vdsm-python-cpopen for package: vdsm-cli-4.13.0-9.el6.noarch
--> Running transaction check
---> Package fence-agents.x86_64 0:3.1.5-25.el6_4.2 will be installed
--> Processing Dependency: telnet for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: sg3_utils for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: python-suds for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: pyOpenSSL for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: pexpect for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl-Net-Telnet for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(warnings) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(strict) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(POSIX) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(Net::Telnet) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(IPC::Open3) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(Getopt::Std) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(File::Path) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(File::Basename) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: perl(Cwd) for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: net-snmp-utils for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: /usr/bin/perl for package: fence-agents-3.1.5-25.el6_4.2.x86_64
--> Processing Dependency: /usr/bin/ipmitool for package: fence-agents-3.1.5-25.el6_4.2.x86_64
---> Package glusterfs-api.x86_64 0:3.4.0-8.el6 will be installed
---> Package glusterfs-cli.x86_64 0:3.4.0-8.el6 will be installed
---> Package libvirt-lock-sanlock.x86_64 0:0.10.2-18.el6_4.14 will be installed
--> Processing Dependency: libsanlock_client.so.1()(64bit) for package: libvirt-lock-sanlock-0.10.2-18.el6_4.14.x86_64
---> Package mom.noarch 0:0.3.2-3.el6 will be installed
---> Package pyparted.x86_64 0:3.4-3.el6 will be installed
--> Processing Dependency: python-decorator for package: pyparted-3.4-3.el6.x86_64
---> Package python-argparse.noarch 0:1.2.1-2.el6 will be installed
---> Package python-dmidecode.x86_64 0:3.10.13-3.el6_4 will be installed
---> Package python-ethtool.x86_64 0:0.6-3.el6 will be installed
---> Package python-inotify.noarch 0:0.9.1-1.el6 will be installed
---> Package python-netaddr.noarch 0:0.7.5-4.el6 will be installed
---> Package python-pthreading.noarch 0:0.1.1-1.el6 will be installed
---> Package sanlock.x86_64 0:2.6-2.el6 will be installed
---> Package sanlock-python.x86_64 0:2.6-2.el6 will be installed
---> Package tree.x86_64 0:1.5.3-2.el6 will be installed
---> Package vdsm.x86_64 0:4.13.0-9.el6 will be installed
--> Processing Dependency: hostname for package: vdsm-4.13.0-9.el6.x86_64
---> Package vdsm-python.x86_64 0:4.13.0-9.el6 will be installed
---> Package vdsm-python-cpopen.x86_64 0:4.13.0-9.el6 will be installed
---> Package vdsm-xmlrpc.noarch 0:4.13.0-9.el6 will be installed
--> Running transaction check
---> Package ipmitool.x86_64 0:1.8.11-14.el6_4.1 will be installed
---> Package net-snmp-utils.x86_64 1:5.5-44.el6_4.4 will be installed
--> Processing Dependency: net-snmp-libs = 1:5.5-44.el6_4.4 for package: 1:net-snmp-utils-5.5-44.el6_4.4.x86_64
--> Processing Dependency: libnetsnmp.so.20()(64bit) for package: 1:net-snmp-utils-5.5-44.el6_4.4.x86_64
---> Package perl.x86_64 4:5.10.1-131.el6_4 will be installed
--> Processing Dependency: perl-libs = 4:5.10.1-131.el6_4 for package: 4:perl-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl-libs for package: 4:perl-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl(version) for package: 4:perl-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl(Pod::Simple) for package: 4:perl-5.10.1-131.el6_4.x86_64
--> Processing Dependency: perl(Module::Pluggable) for package: 4:perl-5.10.1-131.el6_4.x86_64
--> Processing Dependency: libperl.so()(64bit) for package: 4:perl-5.10.1-131.el6_4.x86_64
---> Package perl-Net-Telnet.noarch 0:3.03-11.el6 will be installed
---> Package pexpect.noarch 0:2.3-6.el6 will be installed
---> Package pyOpenSSL.x86_64 0:0.10-2.el6 will be installed
---> Package python-decorator.noarch 0:3.0.1-3.1.el6 will be installed
---> Package python-suds.noarch 0:0.4.1-3.el6 will be installed
---> Package sanlock-lib.x86_64 0:2.6-2.el6 will be installed
---> Package sg3_utils.x86_64 0:1.28-4.el6 will be installed
--> Processing Dependency: sg3_utils-libs = 1.28-4.el6 for package: sg3_utils-1.28-4.el6.x86_64
--> Processing Dependency: libsgutils2.so.2()(64bit) for package: sg3_utils-1.28-4.el6.x86_64
---> Package telnet.x86_64 1:0.17-47.el6_3.1 will be installed
---> Package vdsm.x86_64 0:4.13.0-9.el6 will be installed
--> Processing Dependency: hostname for package: vdsm-4.13.0-9.el6.x86_64
--> Running transaction check
---> Package net-snmp-libs.x86_64 1:5.5-44.el6_4.4 will be installed
--> Processing Dependency: libsensors.so.4()(64bit) for package: 1:net-snmp-libs-5.5-44.el6_4.4.x86_64
---> Package perl-Module-Pluggable.x86_64 1:3.90-131.el6_4 will be installed
---> Package perl-Pod-Simple.x86_64 1:3.13-131.el6_4 will be installed
--> Processing Dependency: perl(Pod::Escapes) >= 1.04 for package: 1:perl-Pod-Simple-3.13-131.el6_4.x86_64
---> Package perl-libs.x86_64 4:5.10.1-131.el6_4 will be installed
---> Package perl-version.x86_64 3:0.77-131.el6_4 will be installed
---> Package sg3_utils-libs.x86_64 0:1.28-4.el6 will be installed
---> Package vdsm.x86_64 0:4.13.0-9.el6 will be installed
--> Processing Dependency: hostname for package: vdsm-4.13.0-9.el6.x86_64
--> Running transaction check
---> Package lm_sensors-libs.x86_64 0:3.1.1-17.el6 will be installed
---> Package perl-Pod-Escapes.x86_64 1:1.04-131.el6_4 will be installed
---> Package vdsm.x86_64 0:4.13.0-9.el6 will be installed
--> Processing Dependency: hostname for package: vdsm-4.13.0-9.el6.x86_64
--> Finished Dependency Resolution
Error: Package: vdsm-4.13.0-9.el6.x86_64 (ovirt-beta)
           Requires: hostname
 You could try using --skip-broken to work around the problem
** Found 23 pre-existing rpmdb problem(s), 'yum check' output follows:
dmraid-1.0.0.rc16-11.el6.x86_64 has missing requires of dmraid-events
ebtables-2.0.9-6.el6.x86_64 has missing requires of /usr/bin/perl
ebtables-2.0.9-6.el6.x86_64 has missing requires of perl(strict)
glib2-2.22.5-7.el6.x86_64 has missing requires of libfam.so.0()(64bit)
gpgme-1.1.8-3.el6.x86_64 has missing requires of gnupg2
hal-0.5.14-11.el6.x86_64 has missing requires of ConsoleKit >= ('0', '0.2.0', None)
hal-0.5.14-11.el6.x86_64 has missing requires of pm-utils >= ('0', '0.10', '1')
hivex-1.3.3-4.2.el6.x86_64 has missing requires of /usr/bin/perl
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(Getopt::Long)
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(Pod::Usage)
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(Win::Hivex)
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(Win::Hivex::Regedit)
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(strict)
hivex-1.3.3-4.2.el6.x86_64 has missing requires of perl(warnings)
1:libguestfs-1.16.34-2.el6.x86_64 has missing requires of /usr/lib64/libfam.so.0
1:libguestfs-1.16.34-2.el6.x86_64 has missing requires of /usr/lib64/libgamin-1.so.0
libvirt-client-0.10.2-18.el6_4.14.x86_64 has missing requires of gettext
libvirt-client-0.10.2-18.el6_4.14.x86_64 has missing requires of pm-utils
policycoreutils-2.0.83-19.30.el6.x86_64 has missing requires of checkpolicy
policycoreutils-python-2.0.83-19.30.el6.x86_64 has missing requires of /usr/bin/make
polkit-0.96-5.el6_4.x86_64 has missing requires of ConsoleKit
selinux-policy-3.7.19-195.el6_4.18.noarch has missing requires of checkpolicy >= ('0', '2.0.21', '1')
tuned-0.2.19-11.el6.1.noarch has missing requires of usermode
Comment 2 Fabian Deutsch 2013-11-14 06:56:35 EST
Are the packages alredady on ovirt.org?
Comment 3 Douglas Schilling Landgraf 2013-11-14 07:09:33 EST
(In reply to Fabian Deutsch from comment #2)
> Are the packages alredady on ovirt.org?

In the beta repo.
https://lists.fedorahosted.org/pipermail/vdsm-devel/2013-November/002746.html

Note You need to log in before you can comment on or make changes to this bug.