Bug 1029261 - NPE building book revision
NPE building book revision
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Lee Newson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 21:18 EST by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 Lee Newson 2013-11-11 23:32:25 EST
Fixed in 1.3-SNAPSHOT build 201311121424

This was caused by the wrong topic being downloaded by the builder because the revision parameter wasn't being used. This then cause populate pass to not populate any XML into the spec topic, which then threw the NPE.
Comment 4 Matthew Casperson 2013-11-12 00:48:34 EST
I can now successfully build old revisions of content specs.
Comment 5 Lee Newson 2013-11-12 00:54:04 EST
Moving to RELEASE PENDING

Note You need to log in before you can comment on or make changes to this bug.