Bug 1029269 - Bugzilla validation does not check capitialisation of keywords
Bugzilla validation does not check capitialisation of keywords
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CCMS-Core (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.3
Assigned To: Lee Newson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-11 21:52 EST by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-03 17:16:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-11-11 21:52:33 EST
When saving a spec through the ui, incorrectly capitialised bugzilla keywords are not flagged as being invalid. They are flagged when the book is built using the csprocessor.

For example, the bugzilla keyword "documentation" will not generate a warning even though the keyword should be "Documentation"
Comment 1 Lee Newson 2013-11-11 23:00:40 EST
Fixed in 1.3-SNAPSHOT build 201311121353

The teiid validator will include the name in the query and then do a comparison after to make sure it matches since the Bugzilla database uses a case insensitive collation. This was done as the normal means of doing via an SQL query (such as using BINARY or COLLATION) don't work with the current version of Teiid used for the VDB.

Note: This version is currently live on the test/development server.
Comment 2 Matthew Casperson 2013-11-24 16:12:59 EST
I have verified that an incorrectly capitalised BZ keyword is flagged as a warning.

Note You need to log in before you can comment on or make changes to this bug.