Bug 1029290 - Unable to create scalable aerogear app
Unable to create scalable aerogear app
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Image (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Farah Juma
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 00:39 EST by Yan Du
Modified: 2015-05-14 20:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 10:07:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
platform log (91.21 KB, text/plain)
2013-11-12 00:40 EST, Yan Du
no flags Details
development log (101.04 KB, text/plain)
2013-11-12 00:40 EST, Yan Du
no flags Details

  None (edit)
Description Yan Du 2013-11-12 00:39:39 EST
Description of problem:

show below error when creating scalable aerogear app in website.

    No ports were left available to map 127.7.177.2:8080: uid=3938
    Aerogear Push Server added. Please make note of these default credentials: User: admin Password: 123 Connection URL: https://$OPENSHIFT_APP_DNS:8443/simplepush MySQL 5.1 database added. Please make note of these credentials: Root User: adminkIVByX9 Root Password: hSfZvsCHbx_C Database Name: aerogear Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/ You can manage your new MySQL database by also embedding phpmyadmin. The phpmyadmin username and password will be the same as the MySQL credentials above.
    Unable to complete the requested operation due to: Failed to correctly execute all parallel operations. Reference ID: 87414b05c332e4664cf35e546fcc08d0




Version-Release number of selected component (if applicable):
devenv_4018
STG



How reproducible:
Always



Steps to Reproduce:

1. create scalable aerogear app via CLI 

#rhc create-app push1s "https://cartreflect-claytondev.rhcloud.com/reflect?github=danbev/openshift-origin-cartridge-aerogear-push" mysql-5.1 --no-git -s

or create the  scalable aerogear app via website




Actual results:

Always got the error:

[root@localhost test]# rhc create-app push1s "https://cartreflect-claytondev.rhcloud.com/reflect?github=danbev/openshift-origin-cartridge-aerogear-push" mysql-5.1 --no-git -s
The cartridge
'https://cartreflect-claytondev.rhcloud.com/reflect?github=danbev/openshift-origin-cartridge-aerogear-push'
will be downloaded and installed
Application Options
-------------------
  Domain:     111
  Cartridges:
https://cartreflect-claytondev.rhcloud.com/reflect?github=danbev/openshift-origin-cartridge-aerogear-push,
mysql-5.1
  Gear Size:  default
  Scaling:    yes
Creating application 'push1s' ... 
Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: d27d1d9a58d2da8694ad758ce11fa475



Expected results:

1. Should create aerogear scalable app successfully.
2. Or if aerogear scalable app is not supported, should disable "scale with web traffic" in website Scaling option as Zend/Jenkins cartridge.




Additional info:

1. aerogear scalable app can be created successfully when testing in INT(devenv_3965).
2. there is a "Not scalable" tag in web console for aerogear app
3. platform.log and development.log attached.
Comment 1 Yan Du 2013-11-12 00:40:10 EST
Created attachment 822762 [details]
platform log
Comment 2 Yan Du 2013-11-12 00:40:38 EST
Created attachment 822763 [details]
development log
Comment 3 Andy Goldstein 2013-11-12 12:03:26 EST
We recently removed "Public-Port-Name:  MESSAGING_THROUGHPUT_PROXY_PORT" from the jbossas and jbosseap cartridge manifest files, and the same change is needed for the aerogear cartridge.
Comment 4 Farah Juma 2013-11-12 14:59:17 EST
I've removed "Public-Port-Name:  MESSAGING_THROUGHPUT_PROXY_PORT" from the aerogear cartridge manifest:
https://github.com/fjuma/openshift-origin-cartridge-aerogear-push/commit/b8ecd123f20be65e8cff129ebc6c8859985937a6

With this change, I no longer see the error. Yan, please confirm as well and then I'll merge this fix into our aerogear cartridge repository. 
(The CLI command to test this is: rhc create-app push1s "https://cartreflect-claytondev.rhcloud.com/reflect?github=fjuma/openshift-origin-cartridge-aerogear-push" mysql-5.1 --no-git -s)

Thanks.
Comment 5 Yan Du 2013-11-12 21:14:25 EST
Test on devnev_4025 and STG, scalable aerogear app can be created successfully, issue have been fixed.


[root@Daphne ~]# rhc create-app push1s "https://cartreflect-claytondev.rhcloud.com/reflect?github=fjuma/openshift-origin-cartridge-aerogear-push" mysql-5.1 --no-git -s
The cartridge
'https://cartreflect-claytondev.rhcloud.com/reflect?github=fjuma/openshift-origin-cartridge-aerogear-push'
will be downloaded and installed

Application Options
-------------------
  Domain:     111
  Cartridges:
https://cartreflect-claytondev.rhcloud.com/reflect?github=fjuma/openshift-origin-cartridge-aerogear-push,
mysql-5.1
  Gear Size:  default
  Scaling:    yes

Creating application 'push1s' ... done

  Aerogear Push Server added.  Please make note of these default credentials:

           User: admin
       Password: 123
 Connection URL: https://$OPENSHIFT_APP_DNS:8443/simplepush


MySQL 5.1 database added.  Please make note of these credentials:

       Root User: adminSvyrTau
   Root Password: Bq29_cnvDDMX
   Database Name: push1s

Connection URL: mysql://$OPENSHIFT_MYSQL_DB_HOST:$OPENSHIFT_MYSQL_DB_PORT/

You can manage your new MySQL database by also embedding phpmyadmin.
The phpmyadmin username and password will be the same as the MySQL credentials above.

Waiting for your DNS name to be available ... done

Your application 'push1s' is now available.

  URL:        http://push1s-111.dev.rhcloud.com/
  SSH to:     5282df81855bafff8c000004@push1s-111.dev.rhcloud.com
  Git remote: ssh://5282df81855bafff8c000004@push1s-111.dev.rhcloud.com/~/git/push1s.git/

Run 'rhc show-app push1s' for more details about your app.


Move bug to verified.
Comment 6 Farah Juma 2013-11-13 10:07:02 EST
Thanks, I've now merged this fix into our aerogear cartridge repo:

https://github.com/aerogear/openshift-origin-cartridge-aerogear-push/commit/6f7d8b83839d72816264a28ba8c5d608b6368837

Note You need to log in before you can comment on or make changes to this bug.