Bug 1029396 - Sometimes JMS client does not failover when journal is disconnected
Sometimes JMS client does not failover when journal is disconnected
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: HornetQ (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Clebert Suconic
Miroslav Novak
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-11-12 05:47 EST by Miroslav Novak
Modified: 2014-10-25 08:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-07 04:55:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miroslav Novak 2013-11-12 05:47:50 EST
Description of problem:
JMS producer does not failover when server is shutdowned due to journal disconnection. This was seen in with AIO journal-type on NFSv4. 

How reproducible:

1. Start 2 servers in collocated HA topology with shared journal on NFSv4 (with AIO journal type). There is queue "testQueue" deployed on both of the servers.
2. Start producer and consumer connected to 1st server sending/reading messages to/from queue "testQueue" (with transacted session)
3. Disconnect 1st server from NFS
4. Wait for HQ component on 1st server to shutdown and clients to failover

Results:
Sometimes happens that producer does not failover.

Issue is under investigation.
Comment 1 Miroslav Novak 2014-07-07 04:55:52 EDT
I was not able to reproduce the issue with EAP 6.3.0.ER9. Closing.

Note You need to log in before you can comment on or make changes to this bug.